Nextcloud Snap + Collabora on Same Server--Help!

tl;dr trying to set up Nextcloud with Collabora, tried reverse proxy with apache and then with nginx and now back to apache, apache now won’t start because of httpd, may have broken the setup for Collabora, help and advice, please!

Relevant information that may help: I’m running Ubuntu 20.04 on this server.

Hi, everybody–

I’m a little stuck, and wonder if I’ve accidentally b0rked my system beyond repair and whether it’d just be easier to wipe my server and start fresh.

At present, I have a Nextcloud on nextcloud . mydomain . com, stored on a Linode server. I am able to log in, upload/download files, edit Task lists, etc just fine. I was hoping to be able to install and configure Collabora, to enable some editing and collaboration on certain projects with some friends.

To set up the Nextcloud, I followed the instructions here and set up Nextcloud through snap with LetsEncrypt, as described here. This part worked fine, configured an A record to let work with my domain provider (Namecheap, if that is relevant). All well and good, got the apps I wanted (minus Collabora) working as expected.

I first tried following the instructions on the website and followed along with this other tutorial, and this seems to be where I ran into some trouble. Around 5:00 into this second video, the creator pulls up several vhosts files. I had none of those files, and so started by creating my own, using his as a template. That didn’t work, so I tried just following the instructions on the official site. Storing the configuration listed in the “Apache reverse proxy” section in the /etc/apache2/vhost.d directory I saw in the video led to SSL errors–saying that it was taking too long to respond. (I don’t know if this was because of editing the paths to the wrong certs, or if it was that I was trying to set up the Collabora on a collabora . mydomain . com–tried editing that in as a trusted domain, and that didn’t seem to fix the problem.)

I decided to apt --purge all the apache stuff, and tried instead to set up an nginx reverse proxy, instead, which was linked from the official site. I ran into errors getting nginx started. Again, using the same config as was there, I also ran into errors. (In both cases, I tried editing the path for the ssl certs to be either those stored in /var/snap/nextcloud/current/certs, or /etc/ssl/(paths-to-snakeoil-certs).) This gave me errors at the command line, but not in accessing the page (no more SSL timeouts). I then apt --purge’d the nginx stuff, deleted the docker container for Collabora, started from scratch, and as I’m trying to set up the apache server, when I reinstalled apache2, it gave me an error that it couldn’t start; apparently, httpd is listening on port 80 and is therefore throwing a fit.

I consider myself knowledgeable enough to be dangerous (clearly, since I’m a little worried I b0rked something), but not knowledgeable enough to dig my way out of the hole I’ve dug with my Google-Fu, and don’t know how to proceed, from here. Should I simply wipe the Linode, set up the Nextcloud from scratch, and try again to set up the Collabora on the same server? Is the problem I’m having recoverable without losing the data on the server (Task lists, etc)? What advice would you offer?

Thanks for any guidance you folks can provide!