Nextcloud-Setup springt nach Abfrage des Admin-Users zurück zur Anmeldemaske

Liebe Community.
Ich bin mittlerweile am Verzweifeln.
Ich habe auf meinem eigenen Github Configs abgelegt, die auf 6 verschiedenen Servern funktionieren (alles DSL). Auf Kabel bekomm ich’s nicht hin.

Router: AVM Fritz!Box 6591 (Vodafone mit nativer IPv4)
Domain + Subdomains bei IONOS (mit DynDNS im selfhosted-Betrieb)

Betriebssystem: Ubuntu 22.04 LTS
Reverse Proxy: Traefik 2.8.4 (als Docker-Compose)
Nextcloud: 24.0.5 (als Docker-Compose)

Problem: Sobald der Docker-Container gestartet wird, fragt NC im Web nach Anlage des Admin-Users und den Zugangsdaten zur MariaDB.

Fehler: NC kommt nicht mit dem Willkommensbildschirm, sondern mit der Anmeldemaske. Ein Anmelden ist jedoch nicht möglich.

Der User wird aber angelegt. Das Datenverzeichnis ist auch da. Nur das Anmelden ist nicht möglich.

Was wurde probiert:

IPv6 intern deaktivert, andere Domains probiert (deSEC), IP intern geändert, Ubuntu neu installiert, andere Docker-Container (Tags) ausprobiert

Leider komme ich nicht dahinter, da ich auch in den Logs nichts finde. Eine Installation mit occ wird auch als successful bestätigt. Ein Login ist trotzdem nicht erfolgreich.

docker-compose.yml (Traefik)
dynamic.yml (Traefik)
traefik.toml (Traefik)
docker-compose.yml (Nextcloud)
.env (Nextcloud)

Mir gehen echt die Ideen aus. Vielleicht hat jemand ein ähnliches Setup…
Herzlichen Dank

Update: Nach dem deaktivieren von REDIS läuft’s.
Jetzt muss ich noch klären, warum - oder, ob ich den überhaupt benötige.