Nextcloud Security Scan: Scan failed!

@tflidd @LukasReschke

I’ve reported the issue at the repository -> Not sure if it’s the right place, though

At the moment the scanner is down - the website works but the actual scans don’t happen. They will come back up - time is needed :clock1:

Same for me. Even after the update to 12.0.1 today.

@jospoortvliet can you fix this soon. There are more and more users asking for it.

1 Like

@LukasReschke any ETA perhaps?

While you are on it I hope you can fix the rating system as posted here too:

Found this thread while trying to look for a solution to the above said issue.
I had thought my NC install was so bad that it cannot detect the instance. LOL

Appreciate the effort put in to solve the issue. Thank you team NextCloud

NC-12.0.1 is NOT detected by

OC- IS detected…

Sadly it is still not fixed.

the scan just checks the version number ( tells you the last version) and the https-headers which can be tested with other tools:

Sure I can use a barrage of tools to do this, but it is still part of the security features Nextcloud provides. I do not think that it is a good idea to have it not working for a month after all. It should be at least marked as not working or taken down if not needed/useful anymore.

I put an issue on github:

1 Like

A bit of otherwise unhelpful background: this is managed by Lukas, who is quite busy with many other things. Running the scanner sadly generates quite a bit of work dealing with automated complaints that can (and did) get the servers shut off.

As soon as Lukas has time, I’m sure he will get to this.

I think the problem still exists…

Then perhaps shut the service down. Or design it differently that it generates less complaints (put some sort of verification into it like the acme challenge or somehow via app that only admin can actively start a scan preferably from this app).



Good news, the scanner is working again.
From my point of view, I’m glad the scanner was fixed and it hasn’t been shut down :slight_smile:

I ope it works for you as well.

well for me it didn’t work just a min ago
running nc 12.0.4. it told me that i’m not on latest patch-level.

so apparently it still is a matter of luck if it works or not.

edit: i just saw that it displayed my last scan from 22-07-2017… at least that was the message that came along with the (wrong) result. just triggered a re-scan an we’ll see

edit2: no changes. re-scan is coming up with the very same (and wrong) result… ans states that it still is from 22-07-17.

I getting the same error that it’s not on the latest patch level but my server is. @jospoortvliet

It showed an older patch level for me as well. So I had to do a re-scan. And that worked for me.

Running Nextcloud
:white_check_mark: Latest patch level
:white_check_mark: Major version still supported
Scanned at 2017-12-07 10:15:50

Sorry, I got excited and hoped it is working for everyone now.


i’m freaking out… i tried it for the 3rd time and now it shows everything allrighty. with date from today.
strangeness has a new name: :wink: