NextCloud reserves twice of storage I upload

I apologize that I am not able to give information like nginx version, logs etc. I use Hetzners Storage Share from Germany and for security reasons they do not want to give this kind of information.

Nextcloud version:
Apache or nginx: nginx

The issue I am facing: basically NextCloud reserved nearly twice of storage I uploaded.
I have bought 500 GB of storage from Hetzner and uploaded around 227 GB. This is what NextCloud is showing me under /settings/user:

Screenshot 2020-08-21 00_37_13

See how the bar is nearly full?

In the Hetzner panel however it shows me this:
Screenshot 2020-08-21 00_38_39

So somehow NextCloud reserved nearly half of the storage.

I already talked with Hetzner support about this, but they say they have no clue and I should address my issue here.

We cleared file versions and disabled file versioning, the issue remains.

I remember having installed this kind of apps for a short period of time:
Ransomware detection / recovery:
Ransomware protection:

I uninstalled these apps again, but could it be that they stored file versions deep down in the directory and did not delete them?

Regards, Ben

1 Like

Hi @Ben1 did you tried to remove significant amount of data, say 50GB? Can you then see used storage is freed proportionally? If not it must be related to some copy still laying around even the apps is not installed anymore…

Did you enable file encryption? I remember they stated encrypted files consume 35% as many storage:

Nextcloud keeps different version of files and files in the trashbin for a while. By default, it only deletes files when the storage is needed for real files. If you have access to the config, you can change these settings…

I solved the problem (for everyone who stumbles on this thread) by doing following:

Nextcloud created a whole lot of .part files when I tried to upload files and then aborted the process. Those .part files were not cleaned afterwards.

This is a common bug right now and they are working on it:

So as of right now it’s best to delete them manually.

1 Like