Nextcloud Pi login screen not loading when accessing from outside my network

I have set up nextcloud pi NextCloudPi_RPi_10-04-18 on my home network.
Nextcloud has been upgraded to 14.0.3.0

The pi is on a static address on the local network. Port forwarding has been set up for both port 80 and 443 to the pi.
I have set up a subdomain to point to my router’s (static) public IP address.
Let’s encrypt has been set up.

I can access both nextcloudpi.local:4443 and nextcloudpi.local on the local network.

However, when I try to access the WUI from I get a timeout error.
I have tried port forwarding both manually set and using UPnP. Results are the same.

This is the header that is returned according to https://monitorbacklinks.com/seo-tools/http-header-status-check when accessing from outside my network:

HTTP/1.1 302 Found
Date: Sun, 21 Oct 2018 14:28:49 GMT
Server: Apache
Expires: Thu, 19 Nov 1981 08:52:00 GMT
Cache-Control: no-store, no-cache, must-revalidate
Pragma: no-cache
Content-Security-Policy: default-src ‘self’; script-src ‘self’ ‘unsafe-eval’ ‘nonce-MmNlWDcwQlROMDVicmtsazVZWTYvV2ZucldRM1RqbFVONFZDVXJiQnU2VT06akt6QzFnUVNmam94bmp3enl2UUNrU0tFd3dwR0ptRWRWTFlNT2ZLcjdPYz0=’; style-src ‘self’ ‘unsafe-inline’; frame-src *; img-src * data: blob:; font-src ‘self’ data:; media-src *; connect-src *; object-src ‘none’; base-uri ‘self’;
X-Frame-Options: SAMEORIGIN
Set-Cookie: oc4owwugr2ac=vrreeifgn9mg1e5j4oo36fqqol; path=/; secure; HttpOnly
Set-Cookie: oc_sessionPassphrase=Ynf%2BayiX3e0hLiJTXtWVJH715TKAulmt8Q5%2BCPWMoQmFJAib210ruQOjgPuWkdnRJEW3XL0O9UJb%2FkcjaYwA2TRJFDJH165QwqS58UetXFh%2Frj0OAB0as0l%2FuWzVCzWp; path=/; secure; HttpOnly
Set-Cookie: __Host-nc_sameSiteCookielax=true; path=/; httponly;secure; expires=Fri, 31-Dec-2100 23:59:59 GMT; SameSite=lax
Set-Cookie: __Host-nc_sameSiteCookiestrict=true; path=/; httponly;secure; expires=Fri, 31-Dec-2100 23:59:59 GMT; SameSite=strict
Strict-Transport-Security: max-age=15768000; includeSubDomains; preload
Referrer-Policy: no-referrer
Upgrade: h2,h2c
Connection: Upgrade
Location: https://my.domain.com/index.php/login
X-Content-Type-Options: nosniff
X-XSS-Protection: 1; mode=block
X-Robots-Tag: none
X-Download-Options: noopen
X-Permitted-Cross-Domain-Policies: none
Content-Length: 0
Content-Type: text/html; charset=UTF-8

The Location value suggests the server is trying to redirect to the login page.
When I try to access the login URL directly, it does not open. Http-header-check for that URL gets an http code 200 returned, however.

Any suggestions what to try next would be great.
Thanks!

Resolved. It appeared to be a NAT loopback issue, which was resolved by disabling NAT Boost on the TPLink router.