Nextcloud only synchronise sometimes

Nextcloud version (eg, 10.0.2): 11.02
Operating system and version (eg, Ubuntu 16.04): Linux mint 18
Apache or nginx version (eg, Apache 2.4.25): ?
PHP version (eg, 5.6): 7.0
Is this the first time you’ve seen this error?: from the installation

Can you reliably replicate it? (If so, please outline steps): yes

The issue you are facing: The outside map is only synchronize ones in a while, (mostly after pauze and force synchronisie)

The output of your Nextcloud log in Admin > Logging: All OK

What can I check or do?

FYI - to determine Apache version in use apachectl -v

There a series of steps to try out for troubleshooting synchronization issues here: https://docs.nextcloud.com/server/11/admin_manual/issues/general_troubleshooting.html

Try those out then report back if there is still no luck.

Thanks for your help.

Apache Version = 2.4.23

Again after disable and enable the external folder in the desktop synch client and than "force synchronise " nextcloud started to synchronize.

Here some logs
15-04-17 20:45:06, nextcloud/zonstr1q_phpbb3.sql.gz, Nextcloud, Gedownload, 20 MB

And

#=#=#=# Syncrun finished 2017-04-15T20:43:47 (last step: 138 msec, total: 957 msec)

#=#=#=# Syncrun started 2017-04-15T20:43:51
#=#=#=#=# Propagation starts 2017-04-15T20:43:52 (last step: 495 msec, total: 495 msec)
#=#=#=# Syncrun finished 2017-04-15T20:43:52 (last step: 117 msec, total: 612 msec)
#=#=#=# Syncrun started 2017-04-15T20:44:07
#=#=#=#=# Propagation starts 2017-04-15T20:44:09 (last step: 1452 msec, total: 1452 msec)
18:44:44||nextcloud/zonstr1q_phpbb3.sql.gz|INST_SYNC|Down|1492223408|fc5ee6e808aa8a224431ec3d7e7d8d88|20961648|00003921ocvkfsqpcxd7|4||0|20869943|1491618608|||INST_NONE|
#=#=#=# Syncrun finished 2017-04-15T20:45:07 (last step: 57941 msec, total: 59392 msec)
#=#=#=# Syncrun started 2017-04-15T20:46:01
#=#=#=#=# Propagation starts 2017-04-15T20:46:02 (last step: 1140 msec, total: 1140 msec)
#=#=#=# Syncrun finished 2017-04-15T20:46:02 (last step: 115 msec, total: 1256 msec)

And the last 3 on the server
{“reqId”:“jU6LeSWn43vNrIaAn3dQ”,“remoteAddr”:“83.46.18.86”,“app”:“updater”,“message”:"\OC\Updater::maintenanceDisabled: Turned off maintenance mode",“level”:1,“time”:“2017-03-29T18:49:40+00:00”,“method”:“GET”,“url”:"/nextcloud/core/ajax/update.php?requesttoken=XC3%2BdoBEI1bmHHCDXlzXvPO%2BAWQR3CYnfQKSVskr6bA%3D%3AMW%2FKIfkqUjOLdzTmDhSh5LbcLlBihH93BXOqNPFnxoE%3D",“user”:"–",“version”:“11.0.2.7”}
{“reqId”:“jU6LeSWn43vNrIaAn3dQ”,“remoteAddr”:“83.46.18.86”,“app”:“updater”,“message”:"\OC\Updater::resetLogLevel: Reset log level to Warning(2)",“level”:1,“time”:“2017-03-29T18:49:40+00:00”,“method”:“GET”,“url”:"/nextcloud/core/ajax/update.php?requesttoken=XC3%2BdoBEI1bmHHCDXlzXvPO%2BAWQR3CYnfQKSVskr6bA%3D%3AMW%2FKIfkqUjOLdzTmDhSh5LbcLlBihH93BXOqNPFnxoE%3D",“user”:"–",“version”:“11.0.2.7”}
{“reqId”:“vRcw6Dul4Ple4eEqANM2”,“remoteAddr”:“83.41.137.17”,“app”:“PHP”,“message”:“Doctrine\DBAL\Exception\DriverException: An exception occurred while executing ‘UPDATE oc_appconfig SET configvalue = ? WHERE (appid = ?) AND (configkey = ?) AND (configvalue <> ?)’ with params [”[]", “core”, “lastupdateResult”, “[]”]:\n\nSQLSTATE[HY000]: General error: 2006 MySQL server has gone away at /home/zonstr1q/public_html/nextcloud/3rdparty/doctrine/dbal/lib/Doctrine/DBAL/Driver/AbstractMySQLDriver.php#116",“level”:3,“time”:“2017-04-06T19:26:07+00:00”,“method”:“GET”,“url”:"/nextcloud/ocs/v2.php/apps/notifications/api/v1/notifications?format=json",“user”:“admin”,“version”:“11.0.2.7”}

If you want more info just ask.

It’s hard to say exactly the issue - this may have to do with system resources. There’s a good list of things to check here: https://dev.mysql.com/doc/refman/5.7/en/gone-away.html

I’ve had database querying errors in the past which have been caused by memory issues. You can see how much memory you have here with free -m. In my case clearing the PageCache helped. If you have a lot of memory then it’s probably something else…

sync
echo 1 | sudo tee /proc/sys/vm/drop_caches

You may also need to restart mysql: sudo systemctl restart mysql

If this works… Then we can figure out ways to prevent this in the future. If not then please look through the mysql posting.

I’m on a shared server so there isn’t much I can do on the serversettings.

I will emplane what I do.

I make every day a backup from a database and in the past I placed the folder from “owncloud” .
After a update that didn’t work any more and I started whit Nextcloud"
But I was reading that it only work if you place the file in a external folder and add that folder to nextcloud.
And as I told, it is only working sometimes.

OK I’m back after some testing.
The desktop client on the same laptop but windows version is working every day without problems.

I can start the Linux version on the following way.
pause synchronize
Click the black arrow left next to " Nextcloud"
Click the back arrow left next to the external folder "nextcloud"
uncheck the folder "nextcloud"
check the folder "nextcloud"
restart synchronize.

Hopefully this is helping to find the problem.

Still no solution?
It is the same on my other laptop (Linux mint 18)
On windows 10 everything works Ok.
So it must be a error in the linux desktop sync client, but very strange that I’m the only one?

I’ve noticed that same strange behaviour on my desktop few days ago. i havent look into it so much but few times had to force sync. I will check if my laptop has similar issues (both running up to date arch).

One year later still the same problem :frowning:

I’d try to sync my files to a different server (e.g. an official test server or you setup a VM in your local network) in order to find out if this problem is related to the client or the server.

If the server turns out to be the problem, it will be hard to isolate the issue because on shared hosting your have only limited access (on the configuration, logs, …) and even if you find a solution, it might be impossible to implement because of your provider. They often use customized environments, so if it was your server, we’d recommend you to start with a default configuration and then slowly change to your environment and check at which point it breaks.

How can it be the server as it is working with the Windows client?

If Windows works it should not be the server, I would try the ownCloud Client to see if the issue happens with the Linux packages they provide as well.

The strange thing is, every first time I use the client on a device it is working.
So after I use the windows version, de linux client is working.
Than if I start mij other laptop with Linux it is working.
Only if I start the same laptop the next day it is working, until I do the steps as I descripe last year

Citaat
I can start the Linux version on the following way.
pause synchronize
Click the black arrow left next to " Nextcloud"
Click the back arrow left next to the external folder “nextcloud”
uncheck the folder “nextcloud”
check the folder “nextcloud”
restart synchronize.
Citaat

The desktop client of Nextcloud is a bit behind the releases of ownCloud, so testing the ownCloud version is a possibility. A different idea would be to test the new version which will be released soon, it should include a lot of bug fixes:

if the problem still exists in that version, it’s probably the best to report this issue to the bugtracker at https://github.com/nextcloud/desktop/issues.