NextCloud on server denied error

My install of NextCloud on my webserver is not updating and I can’t access my files. The error keeps saying denied by server configuration. But I haven’t made any changes and I was able to access my files before.
Anyone can help please.

Unfortunately no-one will be able to help you, if you aren’t providing DETAILED information about your environment/installation, the used software versions, a step-by-step description what you’ve tried to do with which results, the EXACT errors being displayed and any related error messages from the Nextcloud log file.

1 Like

Thanks for responding. I found the solution. I had the line below in my .htaccess file. I removed it and everything is working now.

<FilesMatch “.(phtml|php|PhP|php5|suspected)$”>
Order Allow,Deny
Deny from all

I hade version installed in my cPanel 90.0.9 version included with my iFast hosting services.

The error line attached.

1 Like

Ok, the error messages indeed confirm that you ran into a web server configuration problem. Good to know that you can now use Nextcloud on your server.

Thanks. But I now have a new issue :frowning:
I was able to access ok and initiated the update to v20. Now the site is completely gone. All I’m getting is a 500 error. The tech support for my host says some core php files are missing. Now I’m lost again. Not sure how to fix this prob now.

If the support already knows which php modules are missing, they can tell you the module names so that you can install them on your server to fix the problem.

Support didn’t say what was missing. Said I need to do the installation over. I have files stored on NextCloud and don’t have them anywhere else. Would need to get them back before doing that.

Check the content of the Nextcloud log file to identify the missing modules. Usually an error should have been logged which refers to the missing module.

Hi, thanks for help. I finannly found the log and it said there was an error with an app. Something was missing from it. I deleted the app folder and the page loaded. But it kept going to the upgrade screen and when I tried to update, a error message came up and the same folder was reinstalled. Apparently it’s a discountinued app in NextCloud. I tried changing the config file with the newer version number and the page loaded. I’m now able to access my NextCloud.
Man, what a trouble :slight_smile: Going to remove the app from inside nextcloud and hopefully the issue doesn’t happen again.
Thanks again!

1 Like