Nextcloud on openSUSE not loading JS (solved)

I have installed nextcloud on openSUSE via zypper as described here:

In a virtual machine this was working without any problems, but on my hardware server nextcloud can’t load any JS files and I also have Reference/TypeErrors in the Webdebugger.

Laden fehlgeschlagen für das <script> mit der Quelle "https://XXX/nextcloud/core/vendor    /core.js?v=b729510c". login:22:1
ReferenceError: jQuery is not defined
TypeError: OC is undefined
ReferenceError: $ is not defined
ReferenceError: OCA is not defined

According to the apache log the file the files can be accessed (HTTP 200).
I’ve tried to reinstall nextcloud and looked at the apache and nextcloud logs but couldn’t find any errors. I was able to complete the initial setup via web, but most parts of nextcloud dont’ work.
I suspect that it could be a file permission issue on the htcdocs\nextcloud folder, but I can’t seem to find the necessary default permissions.

Well I’ve found the solution although I’m not sure why.
After disabling IPv6 in openSUSE everything is working.
I wonder why this problem only existed on my hardware server and not inside the VM, but it doesn’t look like a nextcloud topic.