Nextcloud.occ command not found

I am manually setting up a fresh nextcloud server on Ubuntu 20.04 after having performance issues right off the beginning with snap.
I have it running already and now i am in the step on every tutorial where you run this command:

Why do i get command not found? Nextcloud is already running and installed on the server. its in my /var/www/nextcloud directory
i also tried running the command within the directory itself with same result.

Are you still running the snap version?

No. I said MANUALLY setting up as in not using snap AFTER having issues with it.

So i do not need to use this command anymore, i found another guide to install letsencrypt.

I found EVERY installation tutorial guide for nextcloud to be either incomplete, or incorrect on the internet.
I will try to make my own guide step by step for virgin cloud instances that actually makes sense.

I have a fresh install right now encrypted and everything, running OK on hostiso
The snap installation was unusably slow like running the server on an AT286, but the manual installation works good so far.

Thank you

You read EVERY installation tutorial? :grin: For the manual setup, you can’t use the tutorials for snap, nextcloud-pi or other special environments with their specific commands. For letsencrypt, you have to do it your own. There is a letsencrypt program on the ubuntu/debian based systems (https://wiki.debian.org/LetsEncrypt).

Well. Excuse me for missing that little detail at midnight. I suppose I should have been in bed instead of on the forum.

I wrote a pretty thorough guide for running Nextcloud in Docker which has had something like 16k views. I dare say some of those people didn’t find it lacking.

2 Likes

Thank you for the inputs.
Words can be interpreted in many different ways, don’t worry you will be fine.

Im moving on trying to make onlyoffice work now.
Good luck