Nextcloud not working anymore

Support intro

Sorry to hear you’re facing problems :slightly_frowning_face: is for home/non-enterprise users. If you’re running a business, paid support can be accessed via where we can ensure your business keeps running smoothly.

In order to help you as quickly as possible, before clicking Create Topic please provide as much of the below as you can. Feel free to use a pastebin service for logs, otherwise either indent short log examples with four spaces:


Or for longer, use three backticks above and below the code snippet:


Some or all of the below information will be requested if it isn’t supplied; for fastest response please provide as much as you can :heart:

Nextcloud version (eg, 20.0.5): 25.0.3
Operating system and version (eg, Ubuntu 20.04): Debian GNU/Linux 11 (bullseye) aarch64
Apache or nginx version (eg, Apache 2.4.25): nginx/1.18.0
PHP version (eg, 7.4): 7.4.33

The issue you are facing:

Is this the first time you’ve seen this error? (Y/N): y

Steps to replicate it:

  1. Upgrade php from 7.4.33 to 8.1
  2. F*ck configs up and completely destroy the php install so you have only the option to switch back to 7.4.33
  3. Having no clue on what to do next because there are no errors

The output of your Nextcloud log in Admin > Logging:

Nextcloud is not online anymore

The output of your config.php file in /path/to/nextcloud (make sure you remove any identifiable information!):

$CONFIG = array (
  'instanceid' => '****',
  'passwordsalt' => '****',
  'secret' => ****',
  'trusted_domains' => 
  array (
    0 => '',
  'datadirectory' => '/var/www/nextcloud/data',
  'dbtype' => 'mysql',
  'version' => '',
  'overwrite.cli.url' => '',
  'dbname' => 'nx',
  'dbhost' => 'localhost:3006',
  'dbport' => '',
  'dbtableprefix' => 'oc_',
  'mysql.utf8mb4' => true,
  'dbuser' => '****',
  'dbpassword' => '****',
  'installed' => true,
  'default_phone_region' => 'DE',
  'app_install_overwrite' => 
  array (
    0 => 'socialsharing_email',
    1 => 'apporder',
    2 => 'extract',
    3 => 'files_markdown',
  'mail_smtpmode' => 'smtp',
  'mail_smtpsecure' => 'tls',
  'mail_sendmailmode' => 'smtp',
  'mail_from_address' => 'next',
  'mail_domain' => '',
  'mail_smtpauth' => 1,
  'mail_smtpauthtype' => 'LOGIN',
  'mail_smtphost' => '',
  'mail_smtpport' => '587 ',
  'mail_smtpname' => '****',
  'mail_smtppassword' => '****',
  'memcache.local' => '\\OC\\Memcache\\Redis',
  'memcache.locking' => '\\OC\\Memcache\\Redis',
  'maintenance' => false,

The output of your Apache/nginx/system log in /var/log/____:

Output errors in nextcloud.log in /var/www/ or as admin user in top right menu, filtering for errors. Use a pastebin service if necessary.

There are none

Problem is I can’t switch back to 8.1 because I really f*cked up. I rm -r’ed the /etc/php/8.1 and can’t get the configs back because apt won’t create them anymore. I tried everything I could but I have no clue on what to do now and the Cloud was important for me lmao

If it’s important… some sort of backup would be advisable.

Have you tried something like this? Should apply to Debian as well.