Nextcloud not showing files on external hdd

Dear Community, I seem to have a problem with my external HDD and (maybe) permissions?

Here are the required Infos:
Nextcloud version: 23.0.0
Operating system and version : Ubuntu Server 20.04 LTS
Apache or nginx version: Apache/2.4.41
PHP version: PHP 7.4.3

The issue you are facing:
I (successfully) added my USB Hard Drive to my Nextcloud (as seen in this picture)
So, my problem is that I added it, but then had to shutdown my server. So far so good, but when I started it back up, the files just wouldn’t display. (as seen in this picture)
I searched everything and all I got was “check the permissions…”
The config is correct and the files ARE THERE

What I tried myself:

  1. Unmounted the Harddrive to then successfully remount it as ext4
  2. Delete the Harddrive in the “External Storage” App to then successfully add it back in
  3. Change the permissions of /media and /media/Nextext with these commands:
    chown -R www-data:www-data /media/Nextext/
    chmod -R 0750 /media/Nextext/
  4. Changed the Path in the “External Storage” App from /media/Nextext to just /media, which worked…

What can I do now?

Is this the first time you’ve seen this error?:

Steps to replicate it:

  1. Add External HDD with “External Storage” App
  2. Shutdown Server
  3. Wait 5 Minutes
  4. Start up Server
  5. See no Files

The output of your Nextcloud log in Admin > Logging:

Pastebin of Nextcloud.log

The output of your config.php file in /path/to/nextcloud (make sure you remove any identifiable information!):

$CONFIG = array (
  'instanceid' => 'oc50ctqhuijo',
  'passwordsalt' => '****************************',
  'secret' => '**************************************************',
  'trusted_domains' =>
  array (
    0 => 'nextcloud.***********',
  'datadirectory' => '/var/www/nextcloud/data',
  'dbtype' => 'mysql',
  'version' => '',
  'overwrite.cli.url' => 'https://nextcloud.***********/',
  'dbname' => '*********',
  'dbhost' => 'localhost',
  'dbport' => '',
  'dbtableprefix' => 'oc_',
  'mysql.utf8mb4' => true,
  'dbuser' => '**************',
  'dbpassword' => '********************',
  'installed' => true,
  'htaccess.RewriteBase' => '/',
  'mail_from_address' => '**********',
  'mail_smtpmode' => 'smtp',
  'mail_sendmailmode' => 'smtp',
  'mail_domain' => '',
  'mail_smtphost' => '',
  'mail_smtpport' => '587',
  'mail_smtpsecure' => 'tls',
  'mail_smtpauthtype' => 'LOGIN',
  'mail_smtpauth' => 1,
  'mail_smtpname' => '********',
  'mail_smtppassword' => '********************',
  'maintenance' => false,

The output of your Apache/nginx/system log in /var/log/____:

[Sun Jan 23 23:27:04.188814 2022] [access_compat:error] [pid 3638] [client] AH01797: client denied by server configuration: /var/www/nextcloud/data/.ocdata
[Sun Jan 30 21:26:36.042319 2022] [access_compat:error] [pid 1482] [client] AH01797: client denied by server configuration: /var/www/nextcloud/data/.ocdata