Nextcloud Neuinstallation - Internet Serverfehler

Hallo,

ich habe heute Nacht einen eigenen Nextcloud Server aufgesetzt und bekomme nun am Ende der Installation die Fehlermeldung:

Interner Serverfehler

Der Server konnte die Anfrage nicht fertig stellen.

Sollte dies erneut auftreten, sende bitte die nachfolgenden technischen Einzelheiten an Deinen Server-Administrator.

Weitere Details können im Server-Protokoll gefunden werden.

Technische Details

  • Entfernte Adresse: 217.XXX.1XX.X
  • Anfragekennung: oknnDKqiS4vEEEFXXXX

Der nextcloud.log sieht so aus:

{“reqId”:“gkX3meXXXXdj5wePrUm”,“level”:3,“time”:“2019-07-14T07:33:40+02:00”,“remoteAddr”:“XXXXXXX”,“user”:"–",“app”:“index”,“method”:“GET”,“url”:"/",“message”:{“Exception”:“RedisException”,“Message”:“No such file or directory”,“Code”:0,
“Trace”:[{“file”:"/var/www/nextcloud/lib/private/RedisFactory.php",“line”:88,“function”:“connect”,“class”:“Redis”,“type”:"->",“args”:["/var/run/redis/redis-server.sock",0,0]},{“file”:"/var/www/nextcloud/lib/private/RedisFactory.php",
“line”:104,“function”:“create”,“class”:“OC\RedisFactory”,“type”:"->",“args”:[]},{“file”:"/var/www/nextcloud/lib/private/Memcache/Redis.php",“line”:42,“function”:“getInstance”,“class”:“OC\RedisFactory”,“type”:"->",“args”:[]},
{“file”:"/var/www/nextcloud/lib/private/Memcache/Factory.php",“line”:136,“function”:"__construct",“class”:“OC\Memcache\Redis”,“type”:"->",“args”:[“19deb595cd2e10626a904f8eb76ce6aa/lock”]},{“file”:"/var/www/nextcloud/lib/private/Server.php",
“line”:861,“function”:“createLocking”,“class”:“OC\Memcache\Factory”,“type”:"->",“args”:[“lock”]},{“file”:"/var/www/nextcloud/3rdparty/pimple/pimple/src/Pimple/Container.php",“line”:118,“function”:“OC\{closure}”,“class”:“OC\Server”,“type”:"->",
“args”:["*** sensitive parameters replaced "]},{“file”:"/var/www/nextcloud/lib/private/ServerContainer.php",“line”:125,“function”:“offsetGet”,“class”:“Pimple\Container”,“type”:"->",“args”:[“OCP\Lock\ILockingProvider”]},
{“file”:"/var/www/nextcloud/lib/private/AppFramework/Utility/SimpleContainer.php",“line”:165,“function”:“query”,“class”:“OC\ServerContainer”,“type”:"->",“args”:[“OCP\Lock\ILockingProvider”]},
{“file”:"/var/www/nextcloud/3rdparty/pimple/pimple/src/Pimple/Container.php",“line”:114,“function”:“OC\AppFramework\Utility\{closure}”,“class”:“OC\AppFramework\Utility\SimpleContainer”,
“type”:"->",“args”:["
sensitive parameters replaced "]},{“file”:"/var/www/nextcloud/lib/private/ServerContainer.php",“line”:125,“function”:“offsetGet”,“class”:“Pimple\Container”,“type”:"->",
“args”:[“LockingProvider”]},{“file”:"/var/www/nextcloud/lib/private/Server.php",“line”:1812,“function”:“query”,“class”:“OC\ServerContainer”,“type”:"->",“args”:[“LockingProvider”]},
{“file”:"/var/www/nextcloud/lib/private/Files/View.php",“line”:117,“function”:“getLockingProvider”,“class”:“OC\Server”,“type”:"->",“args”:[]},{“file”:"/var/www/nextcloud/lib/private/Server.php",
“line”:655,“function”:"__construct",“class”:“OC\Files\View”,“type”:"->",“args”:[]},{“file”:"/var/www/nextcloud/3rdparty/pimple/pimple/src/Pimple/Container.php",“line”:118,“function”:“OC\{closure}”,
“class”:“OC\Server”,“type”:"->",“args”:["
sensitive parameters replaced "]},{“file”:"/var/www/nextcloud/lib/private/ServerContainer.php",“line”:125,“function”:“offsetGet”,“class”:“Pimple\Container”,
“type”:"->",“args”:[“OCP\Http\Client\IClientService”]},{“file”:"/var/www/nextcloud/lib/private/AppFramework/Utility/SimpleContainer.php",“line”:68,“function”:“query”,“class”:“OC\ServerContainer”,
“type”:"->",“args”:[“OCP\Http\Client\IClientService”]},{“file”:"/var/www/nextcloud/lib/private/AppFramework/Utility/SimpleContainer.php",“line”:98,“function”:“buildClass”,
“class”:“OC\AppFramework\Utility\SimpleContainer”,“type”:"->",“args”:[{“name”:“OC\App\AppStore\Fetcher\AppFetcher”,“class”:“ReflectionClass”}]},{“file”:"/var/www/nextcloud/lib/private/AppFramework/Utility/SimpleContainer.php",
“line”:119,“function”:“resolve”,“class”:“OC\AppFramework\Utility\SimpleContainer”,“type”:"->",“args”:[“OC\App\AppStore\Fetcher\AppFetcher”]},{“file”:"/var/www/nextcloud/lib/private/ServerContainer.php",
“line”:150,“function”:“query”,“class”:“OC\AppFramework\Utility\SimpleContainer”,“type”:"->",“args”:[“OC\App\AppStore\Fetcher\AppFetcher”]},{“file”:"/var/www/nextcloud/lib/private/Server.php",“line”:1521,
“function”:“query”,“class”:“OC\ServerContainer”,“type”:"->",“args”:[“OC\App\AppStore\Fetcher\AppFetcher”]},{“file”:"/var/www/nextcloud/lib/private/Server.php",“line”:1160,“function”:“getAppFetcher”,
“class”:“OC\Server”,“type”:"->",“args”:[]},{“file”:"/var/www/nextcloud/3rdparty/pimple/pimple/src/Pimple/Container.php",“line”:118,“function”:“OC\{closure}”,“class”:“OC\Server”,“type”:"->",
“args”:["
sensitive parameters replaced ***"]},{“file”:"/var/www/nextcloud/lib/private/ServerContainer.php",“line”:125,“function”:“offsetGet”,“class”:“Pimple\Container”,“type”:"->",
“args”:[“OC\Installer”]},{“file”:"/var/www/nextcloud/lib/private/legacy/util.php",“line”:739,“function”:“query”,“class”:“OC\ServerContainer”,“type”:"->",“args”:[“OC\Installer”]},
{“file”:"/var/www/nextcloud/lib/base.php",“line”:653,“function”:“checkServer”,“class”:“OC_Util”,“type”:"::",“args”:[{“class”:“OC\SystemConfig”}]},{“file”:"/var/www/nextcloud/lib/base.php",
“line”:1056,“function”:“init”,“class”:“OC”,“type”:"::",“args”:[]},{“file”:"/var/www/nextcloud/index.php",“line”:40,“args”:["/var/www/nextcloud/lib/base.php"],“function”:“require_once”}],
“File”:"/var/www/nextcloud/lib/private/RedisFactory.php",“Line”:88,“CustomMessage”:"–"},“userAgent”:“Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:68.0) Gecko/20100101 Firefox/68.0”,“version”:“16.0.3.0”}lockquote

Vielleicht kann mir ja einer dabei helfen dem Problem auf den Grund zu gehen oder weiß sogar was da schief gelaufen ist :frowning:

Viele Grüße

Da in den Logmeldung von einer “Redis exception” die Rede ist, möchte ich empfehlen

  • den diesbezüglichen Teil der Nextcloud-Konfiguration zu prüfen.
  • zu prüfen, ob der Redis-Dienst korrekt läuft.
1 Like

Ein “systemctl status redis” gibt folgendes aus:

systemctl status redis
● redis-server.service - Advanced key-value store
Loaded: loaded (/lib/systemd/system/redis-server.service; enabled; vendor preset: enabled)
Active: active (running) since Sun 2019-07-14 17:13:33 CEST; 4min 13s ago
Docs: http://redis.io/documentation,
man:redis-server(1)
Process: 231 ExecStartPost=/bin/run-parts --verbose /etc/redis/redis-server.post-up.d (code=exited, status
Process: 221 ExecStart=/usr/bin/redis-server /etc/redis/redis.conf (code=exited, status=0/SUCCESS)
Process: 210 ExecStartPre=/bin/run-parts --verbose /etc/redis/redis-server.pre-up.d (code=exited, status=0
Main PID: 227 (redis-server)
CGroup: /system.slice/redis-server.service
└─227 /usr/bin/redis-server 127.0.0.1:0

Jul 14 17:13:33 mail systemd[1]: Starting Advanced key-value store…
Jul 14 17:13:33 mail run-parts[210]: run-parts: executing /etc/redis/redis-server.pre-up.d/00_example
Jul 14 17:13:33 mail run-parts[231]: run-parts: executing /etc/redis/redis-server.post-up.d/00_example
Jul 14 17:13:33 mail systemd[1]: Started Advanced key-value store.
lines 1-16/16 (END)

Ich habe redis so konfiguriert:

4. Redis

apt update && apt install redis-server php-redis -y

Change configuration and group membership

cp /etc/redis/redis.conf /etc/redis/redis.conf.bak sed -i “s/port 6379/port 0/” /etc/redis/redis.conf sed -i s/#\ unixsocket/\unixsocket/g /etc/redis/redis.conf sed -i “s/unixsocketperm 700/unixsocketperm 770/” /etc/redis/redis.conf sed -i “s/# maxclients 10000/maxclients 512/” /etc/redis/redis.conf usermod -a -G redis www-data

cp /etc/sysctl.conf /etc/sysctl.conf.bak sed -i ‘$avm.overcommit_memory = 1’ /etc/sysctl.conf

Ich denke da läuft alles so wie es soll, oder?

Du hast immer noch nicht geschrieben, wie Du die Redis-Verbindung in Nextcloud konfiguriert hast. In der config.php-Datei sollte ein entsprechender Absatz zu finden sein.

1 Like

Meinst du dieses hier:

‘logfile’ => ‘/var/nc_data/nextcloud.log’,
‘loglevel’ => 2,
‘logtimezone’ => ‘Europe/Berlin’,
‘log_rotate_size’ => 104857600,
‘maintenance’ => false,
‘memcache.local’ => ‘\OC\Memcache\APCu’,
‘memcache.locking’ => ‘\OC\Memcache\Redis’,
‘overwriteprotocol’ => ‘https’,
‘preview_max_x’ => 1024,
‘preview_max_y’ => 768,
‘preview_max_scale_factor’ => 1,
‘redis’ =>
array (
‘host’ => ‘/var/run/redis/redis-server.sock’,
‘port’ => 0,
‘timeout’ => 0.0,
),

Das steht über redis in der Config.php

Ich meine mich erinnern zu können, dass es bis vor kurzem noch ein Problem bei der Verwendung eines Socket für den Zugriff auf Redis gegeben hat, weswegen bis dato eine Netzwerkverbindung präferiert wurde. Bei mir sieht deshalb die Konfiguration wie folgt aus:

  'redis' =>
  array (
    'host' => 'localhost',
    'port' => 6379,
    'timeout' => 0.0,
  ),

Alternativ kannst Du natürlich einmal prüfen, ob der konfigurierte Socket existiert und wie dessen Zugriffsrechte gesetzt sind:

ls -al /var/run/redis/redis-server.sock