Nextcloud mehrere Festplatten

Eine etwas spezielle frage und zwar wenn ich die nextcloud normal aufgesetzt habe ist die Installation auf der sd karte und um mehr speicher zu verwenden kann man lokalen speicher verwenden nennen wir es festplatte 1 wenn ich diese jetzt einbinde ist die dann als Ordner zu sehen und zudem hat der Benutzer den vollen speicher Zugriff sodass ich diese partitionieren mĂŒsste das er einen bestimmten speicher zu VerfĂŒgung hat kann man es so machen das wenn was hochgeladen wird das dies auf festplatte 1 gespeichert wird ohne zwischen Ordner wenn das geht ist das schön zudem möchte ich Benutzer 1 10 GB geben und Benutzer 2 12 GB was aber auf der ein und der selben festplatte sein soll
die speicher Begrenzung gilt nicht fĂŒr lokalen speicher wie könnte man das machen ich hoffe ihr wisst was gemeint ist

Also es ist schwer zu verstehen, was du willst. Zum Einen wÀre Interpunktion hilfreich, zum Anderen wÀre ein Verfassen der Anfrage auf Englisch erfolgreicher, da das Forum international ist.

Wenn Ich es aber ansatzweise verstehe, willst du die Daten auf die Festplatte auslagern. Das kannst du durch Angabe des Datenverzeichnisses in der Config erreichen. “datadirectory” ist das Stichwort. In der UserKonfiguration kannst du die Quotas einzeln festlegen.

Ich hoffe, es ist das, was du meintest.

Ich habe deine Frage ins deutsche Forum verschoben :wink:

jup das was du willst geht durchaus ^^ es gibt hier zwei möglichkeiten die eine von “dartcafe” â€œĂŒber datadirectory” ĂŒbrigens danke “dartcafe” das du trotzdem versuchst seine frage zu verstehen und ihm hilfst ^^ ich schreib auch ab und an so wie “martin1” XD

das andere wer jedem eine eigene festplatte zuweisen möchte ^^ die hier

doch es betrifft weniger Nextcloud mehr linunx im allgemeinen

google mal nach “linux ordner verlinken” und achte auf “symbolischer und harten Link” aber achtung den “speziellen benutzer” musst du das von hand angeben ^^ aber zum glĂŒck Ă€ndert man das ja nicht jedes mal :wink:

PS: das mit der festplatte hast du ja jetzt und das mit der GrĂ¶ĂŸe machst du dann ĂŒber die cloud wie gehabt ĂŒber die Benutzer einstellungen vom admin also da wo du sie anlegen kannst bei “Quota” die grĂ¶ĂŸe festlegen ^^

Ja das ist das was ich meine da stellt sich noch mir die frage was sind quotas danke das du dir trotzdem die mĂŒhe gemacht hast ich versuche mich zu bessern auf englisch kann ich schlecht fragen da ich einfach kein English kann und Google Übersetzer ist auch nicht so toll

Was ich trotzdem nicht verstehe ist was soll ich da im deteil Ă€ndern soll in der config steht nur /var/www/nextcloud/data wie ich das verstehe wird im diesen Dateien Pfad alle Daten gespeichert und wenn ich den verĂ€nder und den Pfad der festplatte nehme werden alle Daten auf die festplatte gespeichert oder ist die Überlegung falsch

also wenn du auf die admin eisnstellungen gehst dort hin wo du benutzer anlegen kannst dann ist zwischen “Gruppenadministrator fĂŒr” und “Speicherort” die einstellung “quotas” damit kannst du sagen wer wie viel daten bei dir parken darf ^^

nein nein das verstehst du schon richtig nicht alle clouds können mit TBs auf dem standart weg kommen zB ein bananapi auf einer 64GB karte das ist zuwenig ^^ darum kann das die cloud in der config auch Àndern du kannst aber auch einen HARD link mit LINUX setzen geht auch

zB / var / www / nextcloud / data / machst du “data” weg und setzt einen LINUX HARD link oder wenn ein kuppel hast der sagt he ich will auch einen speicher und gibt dir sogar eine platte dann kannst du nach dem er ein konto erstellt hat mit dem namen / var / www / nextcloud / data / TEST / einen LINUX HARD link machen der TEST ersetzt ^^ dann noch in quotas bei ihm die GrĂ¶ĂŸe freigeben und er kann dann seine Platte VOLL nutzen ^^

es gibt da viele wege nach ROM :wink:

Also das mit den quotas hab ich verstanden das mit dem HARD link in linux nicht so ganz ich hab das zwar mal gesucht aber die Anleitung hab ich nicht so ganz verstanden jetzt mal so zum VerstĂ€ndnis der normale Pfad ist der: /var/www/nextcloud/data und der Pfad der festplatte ist der /home/pi/test/ wenn das der Pfad zur festplatte ist mĂŒsste ich den in der config eintragen (der Pfad der festplatte war nur ein beispiel) Danke schon mal fĂŒr die Hilfe

Jup damit kannst due den ordner data der in der cloud ist auf deine festplatte in den ordner test legen :wink:

hard links oder auch symbolischer sind links bei denen der Pfad gleich bleibt also bei symbolischer link ist es so
/var/www/nextcloud/data bleibt da wo es ist und /home/pi/test/ bleibt auch da wo es ist doch jetzt kannst du zB einen ordner in data erstellen zB OLAF ^^ das ist nur ein link aber verweißt dann auf test das heist alles was die cloud in OLAF abspeicher will landet in wirklichkeit bei test ^^

hard links verÀndern die struktur bedeutet /var/www/nextcloud/data bleibt wo es ist aber /home/pi/test/ verÀndert sich und du kannst es dann in OLAF verweisen bedeutet das gleich wie oben ^^

Also so ganz hab ich das noch nicht verstanden muss ich in data einen ordner erstellen nennen wir in olaf und muss ich in dann noch sagen das die festplatte dort hin gemountet wird

Nachtrag jetzt hab ich es schon mal so verstanden aber wie sag ich ihm das er es in Wirklichkeit in den test Ordner legt

https://wiki.ubuntuusers.de/ln/

ln [OPTION]
 ZIEL [VerknĂŒpfungsname]

zb
nehmen wir mal an eine user erstellt einen acc bei dir namens test dann liegt in data ein ordner namens test den kopierts du mal auf die seite dann das im terminal
ln -i -s /home/pi/test/ /var/www/nextcloud/data/test wenn ich es richtig gemacht habe sollte nun in data ein Ordner auftauchen namens test ^^ “der hat einen kleinen pfeil” der wird dann ganz normal verwendet und die colud speichert da alles
was der User hoch ladet ^^ den inhalt von original test musst du halt in den anderen test verschieben^^

wenn ich das eingebe -i -s /home/pi/test/ /var/www/nextcloud/data/test wird im nextcloud data ordner der test ordner an sich auf die festplatte verschoben und der Data Ordner mit dem test Ordner ist dann eine art weiter reich link hab ich das so richtig verstanden? und /home/pi/test muss ich dann durch meinen Festplatten Pfad ersetzen

Also das hab jetzt einfach ausprobiert und es hat ansich funktioniert es nur im Data Ordner werden die User gespeichert wenn ich in einen User rein gehe sind 2 Ordner 1. cache 2. files im Ordner 2 werden alle Daten gespeichert und nicht wo anders weil wenn ich den befehl eingebe wird im user Ordner ein neuer Ordner erstellt (mit dem Pfeil) nur da wird nichts gespeichert wie mach ich das das er den file Ordner verknĂŒpft wenn ich den befehl umstelle sagt er mir das der Ordner (files) nicht ĂŒberschrieben werden kann wenn ich den lösche gibt es in dem User einen internen Server fehler

Lach Ja die rechte des ordners musst du schon auch anpassen aber ja so geht es auch ^^

Welche rechte und wie pass ich die an

Folgend mĂŒssen dem Server noch die Rechte ĂŒber den Ordner nextcloud gegeben werden

chown -R www-data:www-data /var/www/nextcloud

das musst du dann auch mit dem symbolischen link ordner machen ^^ er muss www-data gehören ^^ ansonsten einfach googlen

sorry ich verstehe nicht die rechte hab ich vergeben aber wie vergebe ich jetzt die rechte dem test Ordner und was muss ich dann der nextcloud sagen das die Daten im test Ordner gespeichert werden und nicht mehr im files Ordner also echt Respekt das du dir so viel mĂŒhe gibst trotz den stĂ€ndigen fragen

also das ganze noch mal in zusammenfassung
also du legst einen User an ganz normal ĂŒber die nextcloud ^^ sagen wir Babi
Babi solltest du jetzt im ordner data finden ^^
Jetzt musst du Babi aber auf die seite kopieren
dann machst du das
ln -i -s /home/pi/test/ /var/www/nextcloud/data/Babi
danach kommst du her und den inhalt von Babi den du auf die seite gelegt hast schibst du jetzt ins neue rein ^^
jetzt noch die rechte anpassen
chown -R www-data:www-data /var/www/nextcloud/data/Babi
jetzt sollte der bunutzer Babi ganz normal wieder speicher können aber halt woanderst ^^

Also ich hab jetzt eine anderen weg gefunden so wie es funktioniert jedenfalls danke fĂŒr eure Hilfe ohne euch hĂ€tte ich es nicht geschafft