Nextcloud is in maintenance mode - no apps have been loaded

hi there! @nachoparker

accessing to web i’m getting following message:

This Nextcloud instance is in maintenance mode, so it may take a while.

The page will refresh when the Nextcloud installation becomes available again.

Contact your system administrator if this message persists or appears unexpectedly.


here it’s status of my NCP

Nextcloud is in maintenance mode - no apps have been loaded

NextCloudPi version v0.66.4
NextCloudPi image NextCloudPi_09-23-18
distribution Debian GNU/Linux 9 \n \l
automount yes
USB devices sda
datadir /media/USBdrive/cloud/ncdata
data in SD no
data filesystem ext2/ext3
data disk usage 102G/147G
rootfs usage 4.6G/15G
swapfile /var/swap
dbdir /var/lib/mysql
Nextcloud check ok
Nextcloud version 14.0.3.0
HTTPD service up
PHP service up
MariaDB service up
Redis service up
Postfix service up
internet check ok
port check 80 open
port check 443 open
IP 192.168.1.207
gateway 192.168.1.1
interface eth0
certificates name-server.server.org
NAT loopback yes
uptime 9:21


I have tried to execute following command, but seem it’s not workign:

user-id@nextcloudpi:~$ sudo nextcloud.occ maintenance:mode --off
[sudo] password for user-id:
sudo: nextcloud.occ: command not found

any clue about why my server is entering in maintenance mode without my supervision…?

thanks for your support!

You need to cd to the directory where occ is located or provide the full path default is:

sudo cd /var/www/nextcloud/

then do

sudo -u www-data php occ maintenance:mode --off

also

nc-autoupdate-ncp and nc-autoupdate-nc are most probably enabled.

thanks @OliverV I have executed corrrectly this comamands and maintenance mode has been deactivate.

root@nextcloudpi:/var/www/nextcloud# sudo -u www-data php occ maintenance:mode --off
Cannot load Zend OPcache - it was already loaded
Maintenance mode disabled

at thes point, how can do to avoid that the system enter in maintenance mode atomatically ?

thanks!

Unless you update manually at least every (2 at most) weeks, it is strongly advised to leave nc-autoupdate-ncp and nc-autoupdate-nc enabled. Nacho is our one and only maintainer, he can not support versions older then one month. If you switch them off (run sudo ncp-config, to find them) and want to update, use the tools provided in ncp-config,

the case is that I have the NCP configured to auto update version, but as far as I know or at least I thought, these process was automatic I mean each time that NCP is updated the system configure maintenance mode on and once the update is finished the system put the enviroment in maintenance mode off by itself, but seems that is not the case, for me, due that after each update i need to put the system in maintenance mode off manually.

You seem to be the only one reporting this (so far), maybe check the ncp.log, to see if that contains any clues to what is going wrong with your instance during updates. Low quality power supplies, cables and sd cards are mostly the culprits on rpi’s when strange unexpected errors occur.

there is not much info so far:

my-user@nextcloudpi:/var/log$ sudo cat ncp.log
[ nc-limits ]
Using 3086705664B for PHP
Using 4 PHP threads
Using 3086705664B for Redis

[ nc-limits ]
Using 3086705664B for PHP
Using 4 PHP threads
Using 3086705664B for Redis

[ nc-limits ]
Using 3086705664B for PHP
Using 4 PHP threads
Using 3086705664B for Redis

[ nc-limits ]
Using 3086705664B for PHP
Using 4 PHP threads
Using 3086705664B for Redis

[ncp-update-nc]
Cannot load Zend OPcache - it was already loaded
Current Nextcloud version 14.0.3.0
Available Nextcloud version 14.0.3
Nothing to update

I will wait until next auto-update to check this log.
is there any other log to double check in case i get again that message?

bad news… my ncp has enter again in maintenance mode…! :frowning:
no info saved into ncp.log:

root@nextcloudpi:/var/log# ls -la ncp.log

any other log to check…?

thanks!

Accessing to web i’m getting following message:

This Nextcloud instance is in maintenance mode, so it may take a while.
The page will refresh when the Nextcloud installation becomes available again.
Contact your system administrator if this message persists or appears unexpectedly.

I cannot run solution provided above due to I have hosted server and I don’t have privileges to run “sudo” command. Where else can I turn off maintenance mode. I have access to databases and FTP.

in config.php

https://docs.nextcloud.com/server/stable/admin_manual/maintenance/backup.html#maintenance-mode

1 Like

It works. Thanks a lot.