NextCloud Interface Not Accessible (FreeNAS 11.2)

Support intro

Sorry to hear you’re facing problems :slightly_frowning_face:

help.nextcloud.com is for home/non-enterprise users. If you’re running a business, paid support can be accessed via portal.nextcloud.com where we can ensure your business keeps running smoothly.

In order to help you as quickly as possible, before clicking Create Topic please provide as much of the below as you can. Feel free to use a pastebin service for logs, otherwise either indent short log examples with four spaces:

example

Or for longer, use three backticks above and below the code snippet:

Not only does this problem appear on my main install, but I also can't load the NextCloud iocage I haven't entirely set up yet within itself.

Some or all of the below information will be requested if it isn’t supplied; for fastest response please provide as much as you can :heart:

Nextcloud version (eg, 12.0.2): 15.0.2 I believe
Operating system and version (eg, Ubuntu 17.04): FreeNAS 11.2 (stable)
Apache or nginx version (eg, Apache 2.4.25): whatever was included
PHP version (eg, 7.1): 7.2 (Almost certain from when I watched NextCloud download updates)
The issue you are facing: Web interface is inaccessible

Is this the first time you’ve seen this error? (Y/N): Yes

Steps to replicate it:

  1. Not sure if due to low space on FreeNAS system or (k.erbgjregrsnsjjshlf)

The output of your Nextcloud log in Admin > Logging:

http://s130135568.onlinehome.us/personal/nextcloud-clean.log (190 MB) - Should be up in 30min from 05h45 CST

The output of your config.php file in /path/to/nextcloud (make sure you remove any identifiable information!):

PASTE HERE

The output of your Apache/nginx/system log in /var/log/____:

PASTE HERE

Update: Sorry to say, but the scp and cp commands I found to try and copy the log file out of /var/log don’t seem to work

My SSH skills are limited. I’ve spent time searching, trying (I typed them out as they are suppose to be used), got no error… and no results. I’m using a Mac on 10.14.3. It’s highly possible I have my Desktop target wrong. I don’t know what the full Terminal location string is.


Update: I’ve regained access to my interface… at the expense of switching which ethernet interface to use. I’ve never had to change it till now. There’s one thing I need to know now though, for my next project:

Can I simply map the current files directory to another NextCloud iocage, or will the new one destroy the contents of the old one?


Link to log file in hidden area. Data clean. Should be uploaded by 06h15 CST

Please improve your topic otherwise nobody can help you.

How can I improve it? I have no way of getting anything off it visually, but I can log in via SSH*.

If I make a new NextCloud iocage, it works. But as for why I can no longer access my current one, I am at a complete loss.

*SSH knowledge is limited

Check your webserver log.
Check your nextcloud log.

Add errors to your posting.

The host system is FreeNAS 11.2. No clue how to access the NextCloud log from the console.

Please search the web or read the online documentation.

10 seconds of my life:
https://duckduckgo.com/?q=nextcloud+log+file&t=ffab&ia=web

result:
https://docs.nextcloud.com/server/15/admin_manual/configuration_server/logging_configuration.html

Other info:
How did you install NC? Manually? Using freenas package option?

I thought you might have known off-hand. If I knew you were gonna Quack it, I would’ve Quacked it. :wink:

I installed it using instructions from DanB35’s Github. It has been updated from from NextCloud servers, though the accessibility options (light/dark themes, dyslexic font) are gimped.

Is there a data limit that NextCloud can handle? I was uploading photos/videos from my phone over wifi one day. The next I had no access. It’s not linked to the outside world.

  1. I’d love to get the log file off the server you, but if I can’t get it, it won’t be posted.
  2. Can I link another NextCloud install to my files folder if it’s not encrypted? I know how to map it, and I can easily do without the db folder.

Please invest some time searching for getting the log file. You can use ftp/ssh to get the file.

I tried to get the file via SSH… but that don’t matter now. I got in after I switched from igb1 to igb0 in the connection settings in FreeNAS. I have a different issue I’m curious about now though posted at the bottom of my main post.

OK, for me the problem is still not solved and appeared after I tinkered with LetsEncrypt. Where to can I send the logs? Anything I should omit?

Got all these in /var/log:

httpd-error.log maillog.2.bz2 mount.today sendmail.st sendmail.st.5 userlog xferlog
auth.log debug.log letsencrypt maillog.3.bz2 nextcloud sendmail.st.0 sendmail.st.6 utx.lastlogin
cron devd.log lpd-errs maillog.4.bz2 php-fpm.log sendmail.st.1 sendmail.st.7 utx.log
cron.0.bz2 dmesg.today maillog maillog.5.bz2 ppp.log sendmail.st.2 sendmail.st.8 utx.log.0
cron.1.bz2 dmesg.yesterday maillog.0.bz2 maillog.6.bz2 redis sendmail.st.3 sendmail.st.9 utx.log.1
cron.2.bz2 httpd-access.log maillog.1.bz2 messages security sendmail.st.4 setuid.today utx.log.2

Did you also (like @Scrat) install using my script? If so, the best place for these questions would be on that thread on the FreeNAS forums. And when posting there, it would probably be helpful to describe exactly what you did to “tinker[] with LetsEncrypt.”

I used this tutorial which was more up to date with regards to versions and felt easier to understand: https://www.samueldowling.com/2018/12/08/install-nextcloud-on-freenas-iocage-jail-with-hardened-security/

Samuel is also very active in responding, it would be great if you could somehow team up for a holistic approach.

Pease Help me.

Below page error when i login admin user.

and my shell have no trusted IP i have try to enter but not save im using NAT.2020-12-29

This page isn’t working

192.168.0.160 redirected you too many times.

ERR_TOO_MANY_REDIRECTS

2020-12-29

Hello @zee.malik2008 ,

welcome to the community of Nextcloud.

You responded to an old topic and it looks like you have a different issue.
Please open a new one instead.

Please add all necessary information like Nextcloud version, webserver type and version, os version.

Without additional information the community members cannot help you.

1 Like