Nextcloud Installation with PHP7 [SOLVED]

Hello !

I’m struggling to install Nextcloud with PHP7, which is apparently a requirement to use MySQL / MariaDB with Debian Stretch.
I have successfully installed php7 with the required modules following the “Installation on Linux” on the “Nextcloud 12 Server Administration Manual”.
phpinfo() :

But when i try to access to nextcloud with my browser, the nextcloud/index.php appears.

What can I do ?

Thank you


Your server is delivering as plain text.

I expect because PHP isn’t running properly - have you tried resetting Apache? Or better yet try resetting your whole machine (just to be sure)

You can test if PHP is working by creating a file in your www root called info.php with the contents “<?php phpinfo(); ?>”
(without “”) It should give you the phpinfo page that list modules, settings, ini file etc. If your info.php works fine but your nextcloud/index.php doesnt then I would suggest trying a reinstall - I usually suggest people try the setup_nextcloud.php file as its normally the easiest but you obviously need your PHP working first :wink:

The problem is solved.

The phpinfo(); was working but in an other directory.
I tried to activate some modules without any change (sudo a2enmod php7.0 , … )

I put a group on the nextcloud folder which didn’t have one (sudo chown -R www-data:www-data /var/www/html/nextcloud)

I was struggling for a while but it was the browser which wasn’t refreshing the page, it worked when I tried in incognito mode.

Thank you for your help

Ah yes, always run in incognito or check on a different browser so you know its not a caching issue.

A good life lesson to remember that!

Glad it worked out for you :smiley: