Nextcloud hangs (Gateway timeout) after trying to install app

I’m running Nextcloud using a custom Docker image based on Nginx with PHP-FPM. Yesterday, I moved the /var/lib/docker folter to a new disk. A symlink for Docker to the old location was created. Since I did this, it’s not possible to install or update any app.

I tried

  • Updating Collabora Online from 1.12.34 to 1.12.35
  • Installing Markdown Editor
  • Installing Notes

After I started the installation or update, Nextcloud completely hangs. It’s not useably any more, also not in an new tab. It take some time, when “Gateway timeout” is displayed in the browser. In this case, only a complete restart of the Docker container seems to help.

When I install an app, a red box appears under the app that says, there is an error occured during the activation process of the app. The logs have some entrys like this:

GuzzleHttp\Exception\ConnectException: cURL error 28: Operation timed out after 10000 milliseconds with 0 bytes received
/var/www/html/3rdparty/guzzlehttp/guzzle/src/RequestFsm.php - line 103: GuzzleHttp\Exception\RequestException wrapException(Object(GuzzleHttp\Message\Request), Object(GuzzleHttp\Ring\Exception\ConnectException))
/var/www/html/3rdparty/guzzlehttp/guzzle/src/RequestFsm.php - line 132: GuzzleHttp\RequestFsm->__invoke(Object(GuzzleHttp\Transaction))
/var/www/html/3rdparty/react/promise/src/FulfilledPromise.php - line 25: GuzzleHttp\RequestFsm->GuzzleHttp\{closure}(Array)
/var/www/html/3rdparty/guzzlehttp/ringphp/src/Future/CompletedFutureValue.php - line 55: React\Promise\FulfilledPromise->then(Object(Closure), NULL, NULL)
/var/www/html/3rdparty/guzzlehttp/guzzle/src/Message/FutureResponse.php - line 43: GuzzleHttp\Ring\Future\CompletedFutureValue->then(Object(Closure), NULL, NULL)
/var/www/html/3rdparty/guzzlehttp/guzzle/src/RequestFsm.php - line 134: GuzzleHttp\Message\FutureResponse proxy(Object(GuzzleHttp\Ring\Future\CompletedFutureArray), Object(Closure))
/var/www/html/3rdparty/guzzlehttp/guzzle/src/Client.php - line 165: GuzzleHttp\RequestFsm->__invoke(Object(GuzzleHttp\Transaction))
/var/www/html/3rdparty/guzzlehttp/guzzle/src/Client.php - line 125: GuzzleHttp\Client->send(Object(GuzzleHttp\Message\Request))
/var/www/html/lib/private/Http/Client/Client.php - line 138: GuzzleHttp\Client->get('https //', Array)
/var/www/html/lib/private/App/AppStore/Fetcher/Fetcher.php - line 99: OC\Http\Client\Client->get('https //', Array)
/var/www/html/lib/private/App/AppStore/Fetcher/AppFetcher.php - line 66: OC\App\AppStore\Fetcher\Fetcher->fetch('"2017-09-30 12 ...', '[{"id" "registr...')
/var/www/html/lib/private/App/AppStore/Fetcher/Fetcher.php - line 162: OC\App\AppStore\Fetcher\AppFetcher->fetch('"2017-09-30 12 ...', '[{"id" "registr...')
/var/www/html/lib/private/Installer.php - line 394: OC\App\AppStore\Fetcher\Fetcher->get()
/var/www/html/apps/updatenotification/lib/Notification/BackgroundJob.php - line 258: OC\Installer isUpdateAvailable('activity', Object(OC\App\AppStore\Fetcher\AppFetcher))
/var/www/html/apps/updatenotification/lib/Notification/BackgroundJob.php - line 155: OCA\UpdateNotification\Notification\BackgroundJob->isUpdateAvailable('activity')
/var/www/html/apps/updatenotification/lib/Notification/BackgroundJob.php - line 79: OCA\UpdateNotification\Notification\BackgroundJob->checkAppUpdates()
/var/www/html/lib/private/BackgroundJob/Job.php - line 59: OCA\UpdateNotification\Notification\BackgroundJob->run(NULL)
/var/www/html/lib/private/BackgroundJob/TimedJob.php - line 54: OC\BackgroundJob\Job->execute(Object(OC\BackgroundJob\JobList), Object(OC\Log))
/var/www/html/cron.php - line 147: OC\BackgroundJob\TimedJob->execute(Object(OC\BackgroundJob\JobList), Object(OC\Log))
Undefined offset: 3 at /var/www/html/apps/activity/lib/FilesHooks.php#620
cURL error 56: SSL read: error:00000000:lib(0):func(0):reason(0), errno 104

These log entrys are from about the time where I tested this issue. But I can’t simply reproduce it. Although I changed the log level to debug (0), I don’t get any new log entrys when I try to install an app. The only entry I get is

Scss is disabled for /var/www/html/core/css/server.scss, ignoring

I think that there is some connection to the new disk. It’s conspicuous that I now ran into this issue. But I can’t explain me why. I simply moved the folder and created a symbolic link. In fact this can’t explain why it’s not possible to install new apps. It was surely possible before, a few weeks ago I installed Collabora Online without any problems.

Update #1

Using this documentation, I set all permissions to exclude all permission issues. Won’t work. I also tried in the general settings a update of nextcloud itself (I’m running 12.0.0, latest version at time of writing is 12.0.3). When the button “Open updater” was clicked, a second later I get a error bar that the updater can’t be opened and I should try a manual update. The logs didn’t say anything after doing so. Only a few entrys of “Scss is disabled for /var/www/html/core/css/share.scss, ignoring” appears.