Nextcloud groups, sharing and contacts

I installed nextcloud just for family use and things that in my opinion should be easy seems to be massive problem.

I’m using mobile app to automatically upload photos to camera folder, and I want to make this folder accessible for another registered users.
Unfortunately I couldn’t find option to share folder another way, but just by creating shareable link.
I had idea to create family group which I could join all my users to. I had no problems to add all users to that group, but couldn’t add myself (I’am server admin) - there is no “edit” button for my user in user management.
Also contacts management seems to be broken or I don’t understand it. When I click icon on the right (just by my profile icon) the search box popup for searching users. There are my server users suggested as search result - but they are not clickable. It looks they are in there just for fun. There is also option “show all contact” under the list. If I click that - its moving me to contact list which is completely empty.

For me this is completely crazy.
I feel I wasted whole day to install completely rubbish application that is missing most obvious functionalities.

Mobile app is also not perfect, as auto-uploading doesn’t work for old pictures, and manual upload doesn’t support automatic “date” directories creation as auto-upload does.

Nextcloud version: 18.0.1
Operating system and version: Raspbian 10 (buster)
Apache: 2.4.38
PHP version: 7.3

Can you check with the web developer tools in your browser if all resources are loaded? It sounds a bit like some js/css files are not loaded properly. Check add blocker as well.

Thanks for answer. Unfortunately your suggestions didn’t help.
Everything is loading, ad-block is disabled.

I have idea, that all this may be caused by way of installation.
I was going with the guide and by mistake I used v16 for installation, than updated to 18.0.1.
(Guide was for 16.0.4 or something - I just didn’t change that and just copied/pasted installation link).

PS. I just reinstalled whole thing from scratch using 18.0.1 package and there is no any difference. everything is exactly the same: no edit icon for admin user, contacts in search not clickable, folder sharing greyed out except option to create share link.

This is a bug in 18 up to 18.0.1. It may be fixed in 18.0.2 but it doesn’t seem clear from what I can understand of github.

The workaround is to create another admin user and use that to edit your own admin user profile. Then you will be able to add yourself to the family group.

I agree the contacts list under the icon on the top right is pretty brain dead. I think if you are in a group it will show other users in the group and any you have shared with but it seems pretty random. All you can do is email them. I routinely hide that icon.
The contacts app is your personal list of contacts, you need to add people to (I think you can upload and sync with cardDav but I haven’t tried. You should also be able to share contacts with a group or individuals so create a shared family contacts list and sync to your devices - again I haven’t tried.

1 Like