Nextcloud files not working when posted on forum

Is there a way to fix nextcloud files not being able to be posted on forums ?

Like when you create a shareable link for a video you dont get a .mp4 extension at the end so the forum cant see it as a video.

The same goes for the images. There isnt any extensions at the end. I know that there is a workaround with /preview for the images, but is there something for the videos ?

Im using phpbb and by default phpbb doesnt support videos so I added bbcode for the media and it works by checking extension at the end. But unfortunately nextcloud doesnt have that… So yeah is there a fix for it ?

You can use the sharing option /download. You do not need to allow download in the sharing options. download option only hide download-button.

Here a full HTML-code that works for me. Maybe you need only insert your sharing url with /download in the forum. Maybe it does not work and only in normal HTML with setting type="video/mp4"

<!DOCTYPE HTML>
<html lang="de">
   <head></head>
<body>
<video width="320" height="240" controls>
  <source src="https://cloud.server.tld/s/123456789012345/download" type="video/mp4">
Your browser does not support the video tag.
</video> 
</body>
</html>

video tag: HTML Video

Maybe you must add bbcode extra for video that suffix is not checked.

Maybe you can use the direct link to the file…

Example:

https://cloud.yourdomain.tld/s/eRYKxPHpb6deMk7/download/Nextcloud%20intro.mp4

You can access it by first clicking on the regular sharing link and then copy it from the there dots menu at the top right:

1 Like