Nextcloud ERR_CONNECTION_REFUSED

Hey, ich hab ein kleines Problem, ich komme nicht mehr auf meine Cloud. Nachdem ich versucht habe mir bitwarden selber zu hosten hab ich anscheinend irgendwo was richtig zerstört. Ich komme nicht mehr auf meine Cloud drauf. Fehler: ERR_CONNECTION_REFUSED. systemctl status apache2 sagt failed to start the apache http server. Ich weiß aber nicht was ich falsch gemacht habe. zumindest weiß ich auch das auch ISPconfig bei mir nicht mehr funktioniert.
Der Server läuft auf Debian 9 stable. Ich komme nur noch auf mein webmin. Es ist echt wichtig an die daten zu kommen.

Oder helft mir wenigstens zu sagen wie ich die Daten runterlade ohne auf Nextcloud zu kommen damit ich den Server neu machen lassen kann

Solange deine DB und Files in Ordnung sind hast du gute Chancen alles wiederherzustellen… Arbeite die Schritte der Backup Anleitung durch und damit solltest du alles haben und deine Nextcloud auf einem neuen Server wieder in Betrieb zu nehmen.

du kannst auch diese Threads lesen, es gibt Anleitungen wie man das beste aus einem zerstörten System rauskratzen kann:

okay, jetzt bekomme ich den Fehler: ERR_SSL_PROTOCOL_ERROR

Edit: Nur in Chrome ist dort der Fehler in Opera bekomme ich die apache2 Default Page, kurze Anmerkung: Ich habe Apache2 reinstalliert

Edit vom Edit: Es geht wieder gar nichts mehr

Hallo

sagt in der Regel aber auch in welcher Zeile in welchem Config-File sich der Fehler befindet. Ich w√ľrde sagen dein Problem w√§re l√∂sbar, wenn du deine Config Files wieder auf den Zustand zur√ľckbringst, wie sie vor dem Installationsversuch von Bitwarden waren.

Oder helft mir wenigstens zu sagen wie ich die Daten runterlade ohne auf Nextcloud zu kommen damit ich den Server neu machen lassen kann

Geht es dir nur um die Dateien oder muss die Datenbank auch gesichert werden? (Einstellungen, Kalendereinträge usw)

Falls du nur die Dateien herunterladen willst, befinden sich diese im Nextcloud Datenverzeichnis in einem Unterordner mit deinem Benutzernamen. Herunterladen kannst du sie mit einem FTP-Client wie WinSCP oder Filezilla, oder direkt √ľber die Weboberfl√§che von Webmin, wenn es nicht allzuviele und allzu grosse Datten sind.

Falls du die Datenbank auch sichern willst, m√ľssten wir wissen welche Datenbank du verwendest.

Es geht mir nur um die Dateien. Ich habe es bereits versucht. Jedoch sind die Dateien Fehlerhaft und ich kann sie nicht öffnen :frowning:

Wie hast du sie denn heruntergeladen? Was kommt f√ľr ein Fehler, wenn du sie versuchst zu √∂ffnen? Ist das ein Server bei dir zu hause oder bei einem Hoster?

Das ist ein Server bei einem Hoster warum?

Weil du sonst die Disk direkt am PC anschliessen könntest, um die Dateien allenfalls so zu retten. Aber da wärst du warscheinlich auch selbst darauf gekommen. :wink:

Wenn der Server bei einem Hoster steht, weiss ich leider auch keine andere Möglichkeit als diejenigen, die ich genannt habe…

Kanns sein das die Daten verschl√ľsselt sind und sie deswegen ‚Äúfehlerhaft‚ÄĚ sind?

Standardm√§ssig verschl√ľsselt Nextcloud keine Daten. Das m√ľsstest du bewusst aktiviert haben.

Kann ich die nachtr√§glich deaktivieren? So dass sie sich wieder entschl√ľsseln? Liegt es √ľberhaupt daran? Ich hab einen 2. Server kann ich die Daten so backuppen das ich die cloud vor√ľbergehend auf meinem 2. SERVER habe?

Es gibt zwei Arten der Verschl√ľsselung bei Nextcloud. Server-Side Encryption und End To End Encryption. Bei der ersten Variante werden die Datein, wie der Name schon sagt auf dem Server verschl√ľsselt. Bei der zweiten Variante werden sie vom Client verschl√ľsselt. In beiden F√§llen solltest du irgendwelche Encryption-Keys haben. Inwiefern die Cloud via Webserver erreichbar sein muss, um die Daten entschl√ľsseln zu k√∂nnen, weiss ich leider nicht. Ich denke aber bei der End2End-Variante geht es nur mit dem Nextcloud-Client, was bedeutet w√ľrde, dass die Nextcloud voll funktionst√ľchtig sein muss. Bei der Server-Side Encryption k√∂nnte ich mir vorstellen, dass es u.U. auch via Commandline funktionieren k√∂nnte, wenn du die Encrypotion-Keys gesichert hast. Ich habe aber beide Varianten der Verschl√ľsselung selbst noch nie benutzt und kenne mich nicht damit aus. Schlussendlich wird es hier aber keinen einfachen Workarround geben, ansonsten w√§re der ganze Sinn der Verschl√ľsselung auch etwas in Frage gestellt.

Ich sage es mal so…

Der beste Weg und vielleicht auch der einzige, falls die Daten verschl√ľsselt sind, um wieder an die Daten zu kommen, w√§re wenn du die Nextcloud wieder zum laufen kriegst. Daf√ľr br√§uchten wir aber viel mehr Details um helfen zu k√∂nnen‚Ķ

  1. Hast du verschl√ľsselt oder nicht, wenn ja wie?
  2. Hast du etwas geändert bevor es nicht mehr funktioniert hat, wenn ja was?
  3. Kopiere deine Config Files hier rein (kritische Daten wie Domain Name, Passwörter ändern). Die config.php und die Webserverkonfiguration, wären mal ein Anfang…

…ansonsten bleibt das hier ein Ratespiel.

Nachtrag:

Falls Server-Side Encryption verwendet wurde, habe ich das hier gefunden:

https://docs.nextcloud.com/server/20/admin_manual/configuration_files/encryption_configuration.html#occ-encryption-commands

Interessant wäre vorallem der folgende Befehl:
occ encryption:decrypt-all

Lies dir aber bitte das ganze Thema ‚ÄúEncryption Configuration‚ÄĚ mal durch, bevor du wild irgendwelche Befehle absetzt :wink:

Bei Fragen, fragen :slight_smile:

Das sind die Daten von Apache2 von sites-enabled und sites-available

und das steht in der config.php von Nextcloud !

Ich wei√ü nicht genau was ich umgestellt habe aber die Dateien sind absolut wichtig f√ľr mich.

Ich wei√ü nicht mehr wie ich verschl√ľsselt habe aber das kommt wenn ich eine Datei von dem files ordner versuche zu √∂ffnen ;( image

Edit: Habe was in einer readme.md gefunden was vllt helfen k√∂nnte wegen verschl√ľsselung?
image

Was ich auf anhieb sehe, ist dass deine Apache-Config in der Directory-Direktive relativ leer ausschaut. Bei mir sieht die so aus:

<Directory /var/www/nextcloud/>
Options +FollowSymlinks
AllowOverride All

<IfModule mod_dav.c>
Dav off
</IfModule>

SetEnv HOME /var/www/nextcloud
SetEnv HTTP_HOME /var/html/nextcloud
</Directory>

K√∂nntest du das in der Datei, die sich unter ‚Äúsites-available‚ÄĚ befindet, mal anpassen Du musst das nur im zweiten VirtualHost machen, f√ľr Port 443/HTTPS. Im ersten f√ľr Port 80/HTTP kannst du die Directory-Direktive auch komplett l√∂schen, weil du ja sowieso auf HTTPS weiterletest.

‚Ķ und dann noch √ľberpr√ľfen ob alle ben√∂tigten Module aktiv sind. Einfach die folgenden Zeilen eine nach der anderen im Terminal eingeben. Evtl. musst du sudo davor setzten.

a2enmod rewrite 
a2enmod headers 
a2enmod env 
a2enmod dir 
a2enmod mime

…danach den Apache neustarten.

Bei der SSL-Config fehlt auch noch etwas. Wie hast du die Let’s Encrypt-Zertifikate erstellt? Mit certbot?

Ich glaube schon.

Dann f√ľge nach den SSL-Zertifikaten noch die folgende Linie ein:

Include /etc/letsencrypt/options-ssl-apache.conf

Und noch ein paar Anmerkungen:

  • √Ąnderungen immer nur unter sites-available machen. Danach den Apache neustarten, dann werden die √Ąnderungen automatisch nach sites-enabled √ľbernommen.

  • √úberpr√ľfe, dass der Domainname √ľberall stimmt (ServerName und Zertifikatspfade)

  • √úberpr√ľfe, dass die Pfadangabe (/var/www/nextcloud) zu deinem Nextcloud-Ordner stimmt und an allen Stellen identisch ist.

Wird das mein Problem mit Apache2 √§ndern? Ich bekomme ja den Fehler ‚ÄúFailed to start The Apache HTTP Server‚ÄĚ

Das wäre das Ziel :wink:

Wissen tun wir es wenn du alles was ich gepostet habe ausproboiert hast. Wenn er danach nicht startet, poste bitte die vollständige Fehlermeldung. Falls du das in Webmin machst und dort keine detailierte Fehlermeldung angezeigt bekommst, kannst du es im Terminal mit…

sudo systemctl restart apache2

…versuchen und dann einfach den gesammten Text, der angezeigt wird hier reinkopieren.

“Job for apache2.service failed because the control process exited with error code.
See ‚Äúsystemctl status apache2.service‚ÄĚ and ‚Äújournalctl -xe‚ÄĚ for details.‚ÄĚ

Leider fehler.

Soll ich das auch √ľbernehmen obwohl es vorher funktioniert hat ohne das?


Ich hab mir mal journalctl -xe angeschaut das steht dort