Nextcloud doesn't start

Hi all,

I’m having problems with my nextcloud since a couple of days. At first it just seemed to freeze. I had to reboot and then it worked for a while. In this case the raspberry pi wasn’t reachable (no response to ping).

At the moment I am able to reach the PI but the nextcloud is not reachable via its IP.

Setup:
RasPI 4
NC- PI 1.33.0

And this is what I get when I test apache:

NextCloudPi v1.33.0 is up to date

pi@nextcloudpi:~ $ sudo apachectl -t
AH00526: Syntax error on line 5 of /etc/apache2/sites-enabled/ncp.conf:
SSLCertificateFile: file ‘/etc/letsencrypt/live/mydnsname.duckdns.org/fullchain.pem’ does not exist or is empty
Action ‘-t’ failed.
The Apache error log may have more information.
pi@nextcloudpi:~ $

Can anyone help? Are other details needed?
Thanks in advance

The error message states what need to be checked, so fix the problem and your server should start again.

Hi, thanks for the quick response. I am trying to fix it since a few hours now.
What I found out: all *.pem except for privkey.pem were empty.

In the letsencrypt archive I have **1.pem to **6.pem. **5.pem are not empty.

Here is what I tried:
certbot renew --> ended up in parse failure

or I tried linking the *5.pem from the archive to the actual ones.
certbot renew --> ended up in renew failure

Hope I did not mess up the configuration ;-/

I will try to get this fixed by myself but help would be appreciated a lot.
thanks in advance

Hi again,

solved it. The issue was that certbot always seems to relate to newest files contained in etc/letsencrypt/archive

Here is the solution (in case it helps others at some point):

  1. Deleted all *.pem files in /etc/letsencrypt/live
  2. Deleted the newest (and empty) *.pem files in /etc/letsencrypt/archive which were in my case cert6.pem, …
  3. Created symlinks in …/live pointing to the newest *.pem files containing data (in my case cert5.pem, …)
  4. In the end I had all four files within /live
  5. ran certbot renew --> it worked
1 Like