Nextcloud Docker instance stuck

Hello everybody, a few days running nextcloud, and I’m already in need of help :pensive:

Today I tried to put the server in maintenance mode to solve and issue with a locked file adding the “line” in config.php, and I started getting the error message trying to connect cia web interface:

Internal Server Error

The server encountered an internal error and was unable to complete your request.
Please contact the server administrator if this error reappears multiple times, please include the technical details below in your report.
More details can be found in the server log.

I immediately changed

'mainenance' => true,
with
'mainenance' => false,
but nothing happened, and I’m still stuck with the error page.

I tried to look in the log file, but it keeps to be empty!!!

here the config.php file:
?php
$CONFIG = array (
‘htaccess.RewriteBase’ => ‘/’,
‘memcache.local’ => ‘\OC\Memcache\APCu’,
‘apps_paths’ =>
array (
0 =>
array (
‘path’ => ‘/var/www/html/apps’,
‘url’ => ‘/apps’,
‘writable’ => false,
),
1 =>
array (
‘path’ => ‘/var/www/html/custom_apps’,
‘url’ => ‘/custom_apps’,
‘writable’ => true,
),
),
‘instanceid’ => ‘’,
‘passwordsalt’ => '
’,
‘secret’ => ‘’,
‘trusted_domains’ =>
array (
0 => '
.:’,
1 => '
:’,
),
‘datadirectory’ => ‘/mnt/Storage’,
‘dbtype’ => ‘mysql’,
‘version’ => ‘17.0.0.9’,
‘overwrite.cli.url’ => 'http://
.:’,
‘dbname’ => '
’,
‘dbhost’ => ‘127.0.0.1’,
‘dbport’ => ‘’,
‘dbtableprefix’ => ‘nc_’,
‘mysql.utf8mb4’ => true,
‘dbuser’ => '
’,
‘dbpassword’ => '
*****’,
‘installed’ => true,
‘logtimezone’ => ‘/Europe/Rome’,
‘logfile’ => ‘/var/log/nextcloud/logfile.log’,
‘loglevel’ => ‘3’,
‘maintenance’ => false,
);

I googled around and found only permit related issues, but in my case they look fine:

-rw-r--r-- 1 www-data root        60 Oct  9 21:35 apache-pretty-urls.config.php                                                                                                                                                               

-rw-r--r-- 1 www-data root        70 Oct  9 21:35 apcu.config.php                                                                                                                                                                             

-rw-r--r-- 1 www-data root       377 Oct  9 21:35 apps.config.php                                                                                                                                                                             

-rw-r--r-- 1 www-data root      1117 Oct 14 18:06 config.php    
                                                                                                                                                                          
-rw-r--r-- 1 www-data root     52964 Oct  9 21:35 config.sample.php                                                                                                                                                                           

-rw-r--r-- 1 www-data root       331 Oct  9 21:35 redis.config.php                                                                                                                                                                            

-rw-r--r-- 1 www-data root       669 Oct  9 21:35 smtp.config.php

and logfile:
-rw-r--r-- 1 www-data root 0 Oct 14 13:45 logfile.log

What am I missing?
Any clue?

Thank you very much

Is there a spelling mistake?

mainenance' => true,
with
'mainenance' => false

compared with
‘maintenance’ => false,

usually you don’t edit the config.php file directly – rather use a command such as:

sudo -u www php occ config:system:get maintenance
sudo -u www php occ config:system:set maintenance --value=“true” --type=boolean

Note www might be www-data if on a linux system (depends what the ownership is of your nextcloud directory.

Yeah, that was just a typo error writing the post, as you can see in the copy/pasted config.php the spelling is correct where it counts…:slightly_smiling_face:

sudo -u www php occ config:system:set maintenance --value=“true” --type=boolean

this is a valuable hint. I will follow it next time, I found out, searching the web, that both options are accepted, so I went for the most straightforward for my “experience”.