Nextcloud docker installation on server 2019

Hello im new to nextcloud and docker and im having an issue passing the first screen after instalation where it does not accept my Create new AIO instance saying port 443 is “closed”.

Runing portchecker the port 443 is open! And im postive it open!

Im using Win server 2019 with hyper-V installed and docker desktop.

I have a DDNS domain provided by tplink on my router and it works just fine.
If I make an FTP server or file share on the server and use my DDNS domain it works and has been working great.

However using it on nextcloud 443 port “closed”.

I set docker to use my subnet in config so thats done too.

My biest guess is that docker container runing nextcloud is not automaticly conected to the network?

Any help is appreciated!

Hi, see Nextcloud AIO install - Fails to find OPEN port 443 open - #7 by szaimen and below

Hi thanks for the answer I saw that already but where do I write that in? I have 2 cointainers made by docker one is called nextcloud aio mastercontainer and one is called nextcloud aio domain check…
I click the open in terminal next to it wirte in whats said in that but no avail get could not find -e

You need to stop and remove the mastercontainer first, then recreate it with

sudo docker run -it \
--name nextcloud-aio-mastercontainer \
--restart always \
-p 80:80 \
-p 8080:8080 \
-p 8443:8443 \
--volume nextcloud_aio_mastercontainer:/mnt/docker-aio-config \
--volume /var/run/docker.sock:/var/run/docker.sock:ro \

Thanks I fixed it by removing the containers and on another forum someone put the link to pull it with apache and now im getting different login where I can create username and password!
Will see how this goes!

Hi I managed to install and it works on localhost so I go to https://localhost:8080 and I can access it all works fine!

However from outside I am unable to reach it.
My server internal ip is
I have forwarded ports on router 443,445(using file sharing service),8080,80 to the internal ip of my server.
Also ports are allowed in firewall.
Im using tplink ddns.
If I go to access my file share on my server with domain name I am able to access share files ect.
However connecting to nextcloud does not work I attempted using public ip port and still no avail.
What am I missing? Maybe I need to do something in docker?