Nextcloud + docker + apache

Support intro

Sorry to hear you’re facing problems :slightly_frowning_face: is for home/non-enterprise users. If you’re running a business, paid support can be accessed via where we can ensure your business keeps running smoothly.

In order to help you as quickly as possible, before clicking Create Topic please provide as much of the below as you can. Feel free to use a pastebin service for logs, otherwise either indent short log examples with four spaces:


Or for longer, use three backticks above and below the code snippet:


Some or all of the below information will be requested if it isn’t supplied; for fastest response please provide as much as you can :heart:

Nextcloud version (eg, 20.0.5): Nextcloud AIO v1.3.1
Operating system and version (eg, Ubuntu 20.04): Ubuntu 22.04
Apache or nginx version (eg, Apache 2.4.25): Apache/2.4.52 (Ubuntu)

Hi, I have a docker version of nextcloud running on ubuntu 22.04
In the same server i would run an apache reverse proxy (running on port 443) that also redirect to Nextcloud on port 8443 or 8080
when the docker NextCloud aio run, start 2 images

docker run  -it --name nextcloud-aio-mastercontainer --restart always -p 81:80 -p 8080:8080 -p 8443:8443 --volume nextcloud_aio_mastercontainer:/mnt/docker-aio-config --volume /var/run/docker.sock:/var/run/docker.sock:ro nextcloud/all-in-one:latest-arm64

the result is that also 443 port is reserved by aio-domaincheck

CONTAINER ID   IMAGE                                    COMMAND                  CREATED          STATUS          PORTS                                                                                                                     NAMES
ccb44a23bf65   nextcloud/aio-domaincheck:latest-arm64   "/"              56 seconds ago   Up 54 seconds>443/tcp, :::443->443/tcp                                                                                     nextcloud-aio-domaincheck
a9243b137985   nextcloud/all-in-one:latest-arm64        " /usr/bin/s…"   2 minutes ago    Up 2 minutes>8080/tcp, :::8080->8080/tcp,>8443/tcp, :::8443->8443/tcp,>80/tcp, :::81->80/tcp   nextcloud-aio-mastercontainer

So i can’t run my apache as reverse proxy.
I can move my apache over an other port but i not would…
Can i disable the domain checker? or move to another port?

Is this the first time you’ve seen this error? Y:

Steps to replicate it:

  1. start aio docker image
  2. start apache2 that fails to bind on 443 port

AIO should be the only system by default. But there is a way to instruct it it runs behind a reverse proxy:

1 Like

Hi, tnx.
Worked! I suppose that I must change the internal apache port but I don’t know how…
Now all ok, reverse proxy work and also wildcard certificate.