Nextcloud desktop won't start minimized as it should do

Suddenly my Nextcloud desktop linux app, won’t start minimized, instead it is maximized on every boot and no more system tray icon appear. Closing it it’s not an option, as the sync is stopped too, so I have to keep it on desktop, behind some other apps. Any advice will be appreciate! Thanks!
Linux Debian 10 (Buster), gnome 3.30.2, app version 2.5.1git.

Hey there,

I found that using this gnome-extension:

solved the issue with the application closing instead of minimising to the tray.

I’m also looking for a way to make it start hidden, will update!

OK and to make it start in the background you need to add the --background argument to the Exec in line in your .desktop file.

I’m using Linux Mint but I think that it should be the same as Debian or similar, the .desktop file is shared in ~/.config/autostart/

Hi there! The Topicon extensions seems to be obsolete and it’s giving an error after install. On the other hand, the --backgroud argument doesn’t start the app. I’m using Debian 10 and Ubuntu 20.04.

I’ve got this same problem. Would be nice if the program at least had a minimize button. What gives?

Ok so on Ubuntu Desktop 20.04 I think I got this sorted out now. Two things:

  1. use the --background option for the command in startup:
    Screenshot from 2021-04-01 07-32-45
  2. Delayed the startup for 60 seconds. I can’t remember where I found this but if you search on delaying a startup task you’ll get a variety of methods come up

So now it starts in the tray icon, as I wanted it to:
Screenshot from 2021-04-01 07-34-21