NextCloud desktop client not syncing - Internal server error

No remote folders selected, but many MB of data estimated to be downloaded…

Hi there,
Since more than a month now I have a strange sync problem, that is giving me an “internal server error” and refuses to sync any file between my linux (Ubuntu 22.04) machine and the server.
Nextcloud desktop client version: 3.6.1 (Ubuntu)

I’ve tried removing my account and creating it again. I’m doing a test, selecting a single folder to sync from the server. This folder’s size is ~500KB, but the connection wizard is showing me that it is expecting to download more than 400MB!

The resulting sync does not… sync, throwing me the same “internal server error”.

This MB thing looks weird, and I suspect that my sync problem might be related. Has anyone else experienced something similar?

(other NC accounts - different NC server - sync perfectly OK with the same client. other colleagues of mine - at the same NC server - can sync with the same client)

Sounds like you have narrowed it down to something with your user account. Have you made any manual changes to your data folder on the server?

Thank you for your response @KarlF12.
I don’t have access to the server. For what I’m aware of, no manual changes have been made.

I see. Well, it sounds to me that the issue is only with that specific account on that server, so you’ll need to contact your system administrator for troubleshooting. We really can’t do much on this end if you don’t have access to work on it.

Hi! I am admin of this server having the issue. Server version is 24.0.6. some additional info on the error:

  • other users can sync fine - error currently happening with two users. even a newly created user syncs fine (and shares 80% of folders with the accounts with problems)
  • same user and NC client, with other 2 NC servers being able to sync fine
  • disabling all server addons doesnt help
  • other webdav clients work fine
  • tried with older nextcloud clients and having the same issue (tested down a few versions)
  • no errors on server log
  • error happens even if I select just one small folder to sync (a folder all the other users can sync ok)

So the error is associated to a certain user on a certain server, maybe related to a certain folder properties, even when it is not synced? Unsure
ideas appreciated!
many thanks