Nextcloud desktop client can't connect, but the Owncloud client can

So that’s basically the gist of it. I installed it, it worked the first time, but now it just can’t connect anymore. I am on Ubuntu 18.10. On a windows laptop it doesn’t work either. I can connect with the Android app and the Owncloud client.

I tried to connect via a different Internet, didn’t help. The brute force table in the database was empty, so that was not the problem.

Any tips? I just installed everything a few days ago, so everything should be up to date.

The log doesn’t seem to show any errors, except for this bit maybe:
|[OCC::WebFlowCredentials::stillValid |"Error transferring - server replied: "|
|[OCC::SignPublicKeyApiJob::finished |Sending CSR ended with “ocs/v2.php/apps/end_to_end_encryption/api/v1/public-key” "Error transferring - server replied: " QVariant(int, 400)|
|[OCC::ClientSideEncryption::generateCSR(EVP_PKEY*)::<lambda |400|
|[OCC::Application::slotParseMessage |Running for 129.436 sec|

Looks like something related to the end-to-end encryption. Do you use this feature? The ownCloud-client does not have this feature, therefore you don’t see this bug. It’s probably the best to check the desktop bug tracker and submit a bug report