Nextcloud contacts + DAVx5 on Android (unable to sync)

Hi guys,

  1. I’ve exported my contacts from Google in a .vcf file and succesfuly imported all my contacts to Nextcloud contacts. I can browse them in https : // mydomain / apps / contacts :+1: (I can’t “post more than 4 lynks” as a new user… sorry)

  2. Then I tried the step Sync calendar and contacts from the Nextcloud Android App docs. It prompts me to open DAVx5 and leaves me to the web to grant access. I put my credentials and it says access granted, I close the web and it goes back to DAVx5 and seems to connect (login) to the account… but then, the contacts never appear. DAVx5 has contacts (and calendar) permissions and is not blocked by any power-management measure, it has permissions to run in the background… synchronize… I manually hit refresh…

But it doesn’t sync. I erased the account from DAVx5 and, alternatively to step 2, I did a “manually added” account:

Edit: tried as well domain/remote.php/dav/principals/users/username/, but doesn’t work either.

Any ideas what I am doing wrong?!

As you can see, it seems to detect the path of the contacts… but shows nothing!

Can you check in your webserver logfile when you access via your phone? It should show you what resources are loaded and if it succeeds or fails and from the error codes we can perhaps see a bit more.

You just use your account user and password or did you create an app password. The app-password is required if you have enable two-factor authentication. This is a dedicated password for a special app.

Well, :sweat_smile:

The server (Pi on my best friend’s house) is in 20.0.4. I don’t like to update anything important (like de nextcloud server) if he is not at home and available to run dd and backup my Raspi SSD, just in case :laughing: (so usually it gets done on weekends)

(Also, on github still points to 20.0.4 as latest… so didn’t seem to me like a good option to update to 20.0.6 (specially being far from the Pi).

Also it’s just from mid december 2020… I think everybody is using contacts with DAVx5 from long ago.

Anyway, now I tried to update… and got an error during the update :cold_sweat:. Which I don’t really understand TBO:

I rebooted the Pi and tried again, now it seems to be updating :crossed_fingers:

EDIT: Nothing, the update doesn’t apply. I would have to do it manually. Do you know if it is a 20.0.4 problem??

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.