NextCloud/Collabora - works internally, not externally

I had a post on here the other day regarding my NextCloud/Collabora install because I couldn’t get the two of them to talk. After messing around with the conf files, I was able to get that to work by putting the proxy information on the local collabora instance and then it worked fine.

This is still the same case when I’m internal.

When I’m external, if I’m in NextCloud and click on a document, it opens the document to the point that I see the collabora tools and menu, but the document never actually shows.

My environment is setup like this:

          Proxy Server
          ||             ||
  NextCloud    Collbaora

My proxy server has the following config to direct traffic to collbaora:

    <VirtualHost *:443>
            ProxyPreserveHost On
            ProxyPass /
            ProxyPassReverse /
            SSLCertificateFile /etc/letsencrypt/live/
            SSLCertificateKeyFile /etc/letsencrypt/live/
            Include /etc/letsencrypt/options-ssl-apache.conf
            SSLCertificateChainFile /etc/letsencrypt/live/
            <Location /owa>

Then the collabora has the following conf file:

            SSLCertificateFile /etc/apache2/ssl/fullchain3.pem
            SSLCertificateKeyFile /etc/apache2/ssl/privkey3.pem
            Include /etc/apache2/ssl/options-ssl-apache.conf
            # Encoded slashes need to be allowed
            AllowEncodedSlashes NoDecode
            # Container uses a unique non-signed certificate
            SSLProxyEngine On
            SSLProxyVerify None
            SSLProxyCheckPeerCN Off
            SSLProxyCheckPeerName Off
            # keep the host
            ProxyPreserveHost On
            # static html, js, images, etc. served from loolwsd
            # loleaflet is the client part of LibreOffice Online
            ProxyPass /loleaflet retry=0
            ProxyPassReverse /loleaflet
            # WOPI discovery URL
            ProxyPass /hosting/discovery retry=0
            ProxyPassReverse /hosting/discovery
            # Main websocket
            ProxyPassMatch "/lool/(.*)/ws$" wss://$1/ws nocanon
            # Admin Console websocket
            ProxyPass /lool/adminws wss://
            # Download as, Fullscreen presentation and Image upload operations
            ProxyPass /lool
            ProxyPassReverse /lool

Any thoughts? I tried replacing the loopback with the domain but that just makes it worse.