Nextcloud code integrity check failed after update

Nextcloud code integrity scan check failed after update to 17.03

Technical information

Admin log

Why and what to do about -

appinfo/info.xml
lib/smb.php

(See link )

And pleas feel free to ask for more logs if you need :slight_smile:

i am also getting same error… is there any solution
Thanks

the error-message itself mentions:

  • INVALID_HASH

and then

which means: they don’t have the expected hash… --> nc thinks they are not the originals… so pls download original updaterfile from source, extract both files from there and put them where they need to belong to solve the problem.

and for next issue thread pls use search function of forum first as this problem was already solved here…

thanks and good luck.

Hab den gleichen Fehler. Für alle die in Englischen nicht so gut sind.
Hier die Deutsche Beschreibung. INVALID_HASH
Kurze Anleitung.
Man ladet das Original update von der jeweiligen Version runter.
Entpackt es. Und sucht die Dateien in den Entpackten Archiv.
Und ladet die Dateien in das Verzeichnis der Nextcloud auf den Server.

Viel Erfolg!

@Nanu

thanks for your contribution. but as this is the international part of the forum we’d prefer answers in english from every contributor.
so please try translate.google.com to get your answer(s) translated before posting. it’s just a matter of copy & paste… in both directions… like users being unsure about something could copy some foreigen text from here and get it translated there.

cheers :wine_glass:

1 Like

Cannot find these files “lib / smb.php” “appinfo / info.xml” in source. Which nextcloud does not accept?

Cannot find these files “lib / smb.php” “appinfo / info.xml” in source. Which nextcloud does not accept?

sorry i was unclear about which thing to look at… it seeems to be an app called user_external- you need to find the source of it and í am sure you’re gonna find both files in it.
pls make sure that they belong to the same user than all other files there or change it via chown and take care about their permissions --> chmod to change those

Now I created the permissions so “user_external” folders have the same permissions as the other directories under “/ var / www / nextcloud / apps /” but still have the same issues ?! - Any way I can figure out what extra program it is and remove it?

well by disabling and removing that app it should vanish as well.

This is the solution to my problem (Since there is an error in nextcloud) -