Nextcloud client on Samsung s22 does not auto upload

Greetings everyone! This is my first post so apologies if I did not follow standard posting procedure.

I installed Nextcloud client on S10 and S22, for different NC accounts. It is working fine on S10 but nothing uploads in S22. I went through similar posts but suggested solutions were either not applicable to S22 or did not work. If anyone is running NC on S22 could they provide the additional steps, if any, needed to make auto upload work.

Probably not relevant here but just an FYI that I forgot password to my raspberry NC server.

Nextcloud version: 3.24.2
Phone: Samsung S22
OS: Android 12

The issue you are facing:

Is this the first time you’ve seen this error? Y

Steps to replicate it:

  1. Install Nextcloud client on Samsung S22
  2. In auto upload settings set local folder to DCIM/Camera
  3. Set remote folder to InstantUpload/Camera
  4. Save
  5. Check InstantUpload/Camera folder for any uploads

Update: After this post I noticed that camera was not included in nextcloud permissions settings. After including it the problem still persists.

Samsung s21 owner here. Have done same steps and it works for me without a problem.
Perhaps check preferences which can be set to upload only when on wifi or only when charging. Make sure the little cloud when in auto-upload is filled up (green in my case).

Check in config whether you got the right folder, My folder is /storage/emulated/0/DCIM/Camera.

Sometimes it helps to start over again, remove config and set up a new one. Or setup a custom config perhaps. Good luck.

1 Like

Thanks for the response. Yes, the folder is same and I tried to configure it several times without success. I believe it is some it is some permission issue as some people with other phones (not s22) had similar problem but suggested solution did not work.

In S10 I see nextcloud listed in ‘Permission Manager’/‘Files and media’/‘Allowed to manage all files’ but not in S22. How does it look in S21.

In App info, I have Camera, Contacts, Music and audio, Notifications and Photos and videos permissions. Have version 3.24.2 from Google Play. Perhaps an aggressive battery savings setting? Can’t think of anything else honestly assuming all your other Apps are working fine.

Thanks. Let me check battery settings again. Yes, other apps have no issue.

One other thing which just came to mind; did you try to close the Photo App? Noticed that it sometimes only syncs after I closed the Photo App, but can be coincidence.

After playing with battery and permission setting for few days, it started working one day. I don’t know what solved the issue. Last action was turning on battery optimization.