Nextcloud client fails on Kubuntu 22.04 with "The peer did not present any certificate"

Nextcloud server version: 24.0.5and several older versions tested
Nextcloud desktop version: 3.6.0 and 3.4.2 tested
Operating system and version: Ubuntu 22.04
PHP version: 8.0.20

I regularly use 2 workstations, one laptop and a phone to connect to 2 Nextcloud instances (work and my own). the workstations and the phone is fine, but the laptop stopped being able to connect securely (and when i ignore the error, it repeats constantly).

It all started when I was at a partner university. they seem to use a man in the middle proxy to spy on their users (which i didn’t believe at the beginning, because they are in switzerland). at first there was a certificate error, which i ignored, then there was the message with

Cannot connect securely to vapor.cg.tuwien.ac.at:

#### Additional errors:

The peer did not present any certificate

It pops up constantly, so I can’t use Nextcloud on the laptop. It works on both workstations and the phone as well as on firefox on the laptop. Right now I doubt that the problem is connected with the man in the middle attack (I’m back home, and it still doesn’t work, also not with a clean configuration).

I tried to connect to the host at work (in the message), my own instance, and https://cloudamo.com (which i picked randomly from a provider list).

The stock version on kubuntu is 3.4.2, but I also tried the ppa version. I tried with a new linux user account as well (so with a completely fresh configuration).

The output of your Nextcloud log in Admin > Logging:

empty
(i cleared the log, tried to connect, and nothing was written. i copied the url in the
desktop client and pasted it in the browser to verify it's the correct address)

I hope it’s ok that i refrain from posting the rest of the server information, as it happens with several different servers, and other clients are connecting fine.

I don’t have a whole lot of experience with network stuff, but here is the output of wireshark, when trying to connect: text version, wireshark pcapng

Have the same problem. Uccured after upgrade from nextcloud-desktop 3.1.1 to 3.6.0 on Debian.