Nextcloud-client 3.10.1 sharing options password protect and set expiration date failure when both clicked immediately

Support intro

Sorry to hear you’re facing problems :slightly_frowning_face:

help.nextcloud.com is for home/non-enterprise users. If you’re running a business, paid support can be accessed via portal.nextcloud.com where we can ensure your business keeps running smoothly.

In order to help you as quickly as possible, before clicking Create Topic please provide as much of the below as you can. Feel free to use a pastebin service for logs, otherwise either indent short log examples with four spaces:

example

Or for longer, use three backticks above and below the code snippet:

longer
example
here

Some or all of the below information will be requested if it isn’t supplied; for fastest response please provide as much as you can :heart:

Nextcloud version (eg, 20.0.5): client 3.10.1
Operating system and version (eg, Ubuntu 20.04): Windows 10
Apache or nginx version (eg, Apache 2.4.25): N/A
PHP version (eg, 7.4): N/A

The issue you are facing:

Is this the first time you’ve seen this error? (Y/N):

Steps to replicate it:

  1. Install nextcloud and configure Nextcloud client 3.10.1 and share a folder to your desktop
  2. Right click a folder and choose “Nextcloud|Sharing Options,” Choose “Share Link +” and then click the 3 dots to edit the sharing options
  3. Click “password protect” and “set expiration link” quickly before either operation finishes
  4. Wait for the generated password and the expiration date to be populated
  5. Close the sharing dialog
  6. Open the sharing dialog again and click the 3 dots on the share link option
  7. Only one of “password protect” or “set expiration date” is checked

Expected behavior:
7. Both password protect and set expiration date are populated

Workaround:
3. Click one checkbox, wait for it to populate and then check the next checkbox (takes about 4 seconds each)

Additional notes:
When unchecking these options, there is no error. Closing the dialog and re-opening correctly shows the options turned off.

Also, when done directly from the nextcloud web portal, this SAME SEQUENCE DOES NOT HAVE THIS BEHAVIOR - password and expiration are both correctly set.

The output of your Nextcloud log in Admin > Logging:

N/A

The output of your config.php file in /path/to/nextcloud (make sure you remove any identifiable information!):

N/A

The output of your Apache/nginx/system log in /var/log/____:

N/A

N/A


Output errors in nextcloud.log in /var/www/ or as admin user in top right menu, filtering for errors. Use a pastebin service if necessary.

N/A