Nextcloud CalDAV/CardDAV setup on Windows 10 doesn't work anymore


The setup instructions as described here: Synchronizing with Windows 10 — Nextcloud 15 User Manual 15 documentation do not work anymore on the later builds of Windows 10. I successfully set it up on my workstation a few months ago, but now I also tried to set it up on my laptop and I just can’t.

When I try to add a fake iCloud account, it fails and won’t let me continue without providing correct credentials. I couldn’t even sign into my real iCloud account without setting up a new iCloud email address first (same error, even with a correct app password, but with my Apple ID email instead of an address). After setting up an iCloud address, I was able to add my real iCloud account to Windows, but the advanced settings button where I could enter custom CalDAV/CardDAV URLs is gone.

I do not know when Microsoft changed this behaviour, but it must be quite recent. I am on Windows 10 Pro 20H2 right now, but the problem can also be reproduced on the previous version (I just updated to see if it brings back this functionality, but it doesn’t).

Any ideas how else I can set up my Nextcloud calendars and contacts in Windows 10?

UPDATE: For whatever reason, I am still able to add new fake iCloud accounts to my workstation, but not to my laptop. Both are running the same Windows build (19042.630). Both are also running the same version of the Calendar app (160005.13228.41011.0). On the laptop, however, I have an option to try a new beta version of the Calendar app, which changes the UI significantly. On the workstation, I don’t. Even though the build is the same, I suppose Microsoft is selectively rolling out betas to devices, which drop support for adding custom calendars. Unfortunately, opting out of the beta doesn’t bring CalDAV support back.

Yea, something broke in Windows Calendar :frowning: I used it mainly with a Synology disk station but tested Nextcloud Calendar as well.

The fake iCloud still can be created on my W10 machines and it will even receive events from the remote calendar. But events created in the Windows Calendar will not sync back to nextcloud (or the synology disk station)

Sad :frowning:

I think I found a solution. [sorry for deleting the earlier post, it’s because I thought I didn’t get it working]. Original post here, and down below the steps.

I too had the problem as described. Yesterday I was (unfortunately) migrating from linux to windows, and successfully configured the caldav in the windows mail client. Later, I discovered I somewhat messed up my nextcloud client configuration (for another reason, does not matter), so I decided to just wipe everything out and install windows again (the exact same usb windows installation drive). This time, the fake icloud configuration hanged forever.

The fix: I deleted my default mail account (outlook). Now, when I did the trick again, I was magically welcomed with a little cute sketch on the pop-up window and the button to press “done”. Then proceed as usual ( the caldav option should be in “Change mailbox sync settings”>“Advanced mailbox settings”

One tip: be careful to change to the real password immediately, because windows may trigger your bruteforce prevention native app or the fail2ban if configured.

1-delete your default account (mine was an outlook)
2-add new account> icloud
3-put some fake but pretty email here, something like me@nextcloud (you wont be able to change later
4-send your messages using name or password does not matter. fill with gibberish.
5-click sign in
6-you should see a page with: All done! mail gets even better with outlook on the phone… and click in done.
7-Now you have an account that starts with (!id. Click on it and in “change settings”
8-Fill as this:
username: your nextcloud username
password: your nextcloud app generated password, if you have two factor auth (go in settings>security in your nextcloud, scroll down).
account name: you can fill with anything. Just put “Nextcloud” in.
9-go to change mailbox sync settings in the same window
10-Toggle off contacts, and email.
11-Click on advanced mailbox settings
12-fill both calendar (caldav) AND contacts (carddav) with your nextcloud address (otherwise windows will nag you with “your calendar is not up to date” or something the like. The address in question can be copied from your nextcloud calendar app>settings and import>copy primary caldav address

It should work (for now).