Nextcloud box rainbow screen on start up

Got my box 2 days ago. Followed the instructions but and placed a RPi2 V1.2 inside the box. Inserted SD card provided but the system would not pass the rainbow screen over the hdmi output. After some research found out that means the system actually not booting, just graphic mode test.

Then following advice on the #Nextcloud IRC channel reflashed the SD card with the official image. But same result. After some more research tried to do the same flahsing the RPi3 image (since it seems the RPi2 V1.2 has same processor as RPi3, or so I’ve been told). Then again same result, rainbow screen.

Wondering if it would mean a faulty Pi2 or SD card i decided to flash a Raspbian image. To my surprise it worked flawlessly!! Raspbian system booted up and could even get a Nextcloud instance running on the SD card.

But I’m very upset that the provided image or any of the images linked in the official channels does not start on my box.
Any advice on how to fix that now that I know that I don’t have faulty hardware?


Hi, same issue here, a little help from the mods ?

This topic has been covered to death, please search the existing topics for a solution first:

I know and I have, which is precisely why I replied to this topic and the other one, so that the questions would be brought back… They might have been covered to death but no solution has been found yet…

Is it really all there is to do ? Install Raspbian and Nextcloud subsequently ? Will it work the same and are there precise things to do to make sure it will work ?

PS: perhaps in the Nextcloud box page the model of the Raspberry Pi should be specified, and not just Pi2 since not all Pi2 models work with this image.

Then you haven’t read through the solutions.
Most of the time this is a:

  • Bad image
  • Incorrect SD write
  • Bad SD card
  • Faulty Pi
  • Incorrect Pi revision for the older NC image

The version of Pi you need is stated in one of the topics that come up in search, but other than that:

  • Try a new SD card
  • Redownload the image
  • Download the other image (the earlier official image is just Ubuntu server with Snappy, the newer is actually Ubuntu Core)
  • Try another image writing app.

Agreed. @jospoortvliet


I spent a week trying all the solutions you mentioned above…to my
uttermost despair. Yes, all of them, several times. Wasted hours on forums,
IRC channels, searching for solutions.
In the end, installing raspbian and Nextcloud afterwards took me less than
an hour and it has been working flawlessly for well over a month now.

It’s the same set of images thousands of others use with no problems though, so it must be something resolvable. Perhaps one day we’ll discover the model b 1.x came in two capacitor options and the latter caused a boot panic or something…

Well, ok ! I managed to make it work using one of your pieces of advice !
I used Etcher (on Linux Mint) to write the Pi2 (not pi2/pi3 btw, what’s the main difference ?) Ubuntu Core image into my SD card and it worked !

So, I don’t know if you had already tried it @leousa but in my case it ended up working !

1 Like

Etcher is a good app. Glad it worked.

The Pi 3 is an upgraded board family with better specs. At some point they revised the Pi 2 model B rather than upping the version number, which means the image lost compatibility and for a while no one knew why.

Plenty of info on elGoog if you want to get into the nitty gritty of the changes, essentially the older NC image only supports the earlier Pi 2 B revision, and the newer image supports the newer boards.