Nextcloud Box maximum file space

I’ve got the Nextcloud Box with a Raspberry Pi 2 in it.

While the drive is 1TB, I’m getting a message that 200GB makes it 97% full.

Is this because the Pi is running a 32-bit operating system or is there something I can do to allow the device to use more of the hard drive?

Run a df -h and see if perhaps the disk was partitioned incorrectly. You’ll see there is an “avail” column and you can match it up accordingly with the drive/partition your nexctloud storage is on

Can’t argue with that since I was going to do exactly that, but I thought perhaps given the Nextbox is a standardized machine I might get other suggestions.

Pulling up that information does reveal the problem, but I don’t know what to do about it. It appears there’s something taking up a whole lot of space on sda2, much more that I actually have stored in Nextcloud.

Filesystem Size Used Avail Use% Mounted on
udev 450M 0 450M 0% /dev
tmpfs 93M 14M 79M 15% /run
/dev/sda2 915G 863G 5.8G 100% /
tmpfs 461M 0 461M 0% /dev/shm
tmpfs 5.0M 0 5.0M 0% /run/lock
tmpfs 461M 0 461M 0% /sys/fs/cgroup
/dev/mmcblk0p1 64M 49M 16M 76% /boot/firmware
/dev/loop7 174M 174M 0 100% /snap/nextcloud/3322
/dev/loop3 174M 174M 0 100% /snap/nextcloud/3685
/dev/loop0 71M 71M 0 100% /snap/core/3443
/dev/loop2 71M 71M 0 100% /snap/core/3606
/dev/loop4 175M 175M 0 100% /snap/nextcloud/4378
/dev/loop6 71M 71M 0 100% /snap/core/3750
tmpfs 93M 0 93M 0% /run/user/1000

Which filesystem are you using one sda2?

I’m not sure what you mean by which filesystem am I using. This is the setup as created by using the Nextcloud Box image on the SD card that came with it. Whatever that is, that’s it.

Is there a command line command or combination of commands that would tell the answer to that question?

In general, I would expect all the workings required by the Nextcloud software would be on /dev/sda2. Those /dev/loop# lines appear to be created by each update?

I understand that such questions would be necessary if I were running Nextcloud on some unspecified setup, but in this case I received the Nextcloud Box, set it up as instructed with the SD card that came with it, and that’s the extent of the setup. I haven’t made any special changes to the environment.

In the meantime, I’m going to try some commands I am unfamiliar with to get some details on what is using all that space. Variations on the “du” command I believe.

df -T
should list the filesystems. I have no special experience with the nextcloud box just the idea that it might be some snapshots that are using up the space.

I suspect the same thing. One or more updates moving everything over and leaving behind the previous file set.

This is the result of the df -T command at the level I get put on when I remove into the box over ssh:

ubuntu@ubuntu-standard:~$ df -T
Filesystem Type 1K-blocks Used Available Use% Mounted on
udev devtmpfs 460448 0 460448 0% /dev
tmpfs tmpfs 94216 14084 80132 15% /run
/dev/sda2 ext4 959206864 904493720 5965216 100% /
tmpfs tmpfs 471068 0 471068 0% /dev/shm
tmpfs tmpfs 5120 0 5120 0% /run/lock
tmpfs tmpfs 471068 0 471068 0% /sys/fs/cgroup
/dev/mmcblk0p1 vfat 65480 49592 15888 76% /boot/firmware
/dev/loop7 squashfs 177792 177792 0 100% /snap/nextcloud/3322
/dev/loop3 squashfs 177792 177792 0 100% /snap/nextcloud/3685
/dev/loop0 squashfs 72576 72576 0 100% /snap/core/3443
/dev/loop2 squashfs 72576 72576 0 100% /snap/core/3606
/dev/loop4 squashfs 178816 178816 0 100% /snap/nextcloud/4378
/dev/loop6 squashfs 72576 72576 0 100% /snap/core/3750
tmpfs tmpfs 94216 0 94216 0% /run/user/1000

I attempted to get more information that might be useful. Where was all this stuff taking up far more space than expected. A series of “du” commands got me down to the level of /var/snap/nextcloud/common/nextcloud

I can’t “cd” into nextcloud at the level because “Permission denied”. Since sudo doesn’t work, I’m not sure how I get past that.

865G total
865G .
862G ./var
2.4G ./snap
662M ./usr
330M ./lib
71M ./boot
11M ./bin
8.2M ./sbin
6.9M ./run
5.5M ./etc
188K ./root
80K ./tmp
52K ./home
16K ./lost+found
4.0K ./srv
4.0K ./opt
4.0K ./mnt
4.0K ./media
0 ./sys
0 ./proc
0 ./dev

Drill down in /var it looks like:

ubuntu@ubuntu-standard:/var$ sudo du -ch -d 1 | sort -hr

862G total
862G .
861G ./snap
890M ./lib
61M ./cache
2.1M ./log
1.5M ./backups
44K ./tmp
28K ./spool
4.0K ./opt
4.0K ./mail
4.0K ./local
4.0K ./crash

Drill down in /snap then:

ubuntu@ubuntu-standard:/var/snap$ sudo du -ch -d 1 | sort -hr

861G total
861G ./nextcloud
861G .
20K ./core

Drill down in nextcloud:

ubuntu@ubuntu-standard:/var/snap/nextcloud$ sudo du -ch -d 1 | sort -hr

861G total
861G .
858G ./common
875M ./4378
838M ./3685
806M ./3322

Drill down in common:

858G total
858G ./nextcloud
858G .

There seemed to be more in the trash than I expected. I didn’t see a total size indicator, but I’ll see what the result of selecting everything and deleting it is.

I’ve been waiting many minutes for the spinning circle to stop spinning. Either something is stuck, or it takes a lot of work to get rid of whatever was in the trash bin.

The size of the files in the trash bin seems to have been the issue. df -h indicates the used space is down to 243GB after I deleted everything in there, which is probably about right.

If there was some screen in the web interface for Nextcloud that could have told me about this situation, and I did look right off, I didn’t find it.

For the future try to set a trashbin retention policy in

like described here:

since cd is not a program in the classical sence, you cant sudo it. Try

sudo su -

to switch to the root user. Be careful. Working as root is not recommended, but preferable to weakening permissions on the data folder. Only use that if you know exactly what you are doing.

Indeed, I remembered that sudo su business while driving home. Forget what I used it for last time, and I believe I just tried it to get some job done and was amazed that it worked.

Might even have been for one of my previous own/Nextcloud installs.

I was puzzled that there was no retention policy setting I could find in the admin screens. Good to know there is such a thing you can get to if you need it.

You should take a look at config.sample.php (same folder as config.php)
There are a ton of useful config settings in there with explaination, which are not available via th WebGui