Nextcloud box connection issues still on going

I posted a few months ago about connection issues with my nextcloud box and I am still trying to fix it using searches, etc of the forums, wiki and web searches. No where is giving me what I need.

For a while I was able to access it on my tablet using the ip address but that didn’t always work. After alot of messing around I started from scratch again and while I can access the device via firefox on my linux laptop and I am unable to access it via firefox past the message that the address is untrusted, once I click on the button to allow access I get a blank page telling me that the server cann’t be reached.It is still not working at all on my phone.

When I type in arp -a I get the following for the box

nextcloud (***.***.1.128) at b8:27:eb:7d:55:b5 [ether] on wlp2s0
? ( at on wlp2s0

I am unable to login into ssh to check the connections due to the known passwords including the one in the wiki.

So can someone please tell me what the error message above means and also can someone please suggest the commands needed to access config/config.php via ssh. I have searched for the answer to the commands required for a while as I am still not 100% sure of the command line. I would install the snap for web connections but see above for reasons on access denied.