Nextcloud auf Raspberry nicht mehr erreichbar

Ich habe auf einem Raspberry 4 Nextcloud 20.0.6 eingerichtet. Funktioniert soweit.
Aber wenn ich am nĂ€chsten Tag auf Nextcloud zugreifen will, funktioniert das nicht. Ich muß den Pi neu starten. Habe schon mit unterschiedlichen Neuinstallationen gearbeitet. Seit einiger Zeit immer das Gleiche. Erst nach Neustart wieder Zugriff. Wie gehe ich am Besten bei der Fehlersuche vor?

Wie hast Du das getan, welche Variante?

Debian Buster lite installiert. Dann nach einer der 300 unvollstÀndigen/unbrauchbaren Anleitungen im Netz Appache2 und Maria DB installiert. Und dann Nextcloud. Habe vorher auch fertige Images versucht. Da kam ich gar nicht damit klar.

https://docs.nextcloudpi.com/en/how-to-install-nextcloudpi/

Das wÀre die Anleitung meiner Wahl.

Direkt zu deinem Problem kann ich leider nichts sagen, ich vermute ein Treiberproblem.

Hm, wenn Du eh ein neues System aufgesetzt hast und demzufolge noch keinen Webserver mit bestehenden Diensten laufen hast, hÀttest Du eigentlich auch ein NextcloudPi Image installieren können, da sind Webserver, Datenbank und alles eigentlich schon vorkonfiguriert.

Was sagen denn die Logs Deines Webservers dazu? Ist der apache2-Service noch aktiv, wenn die NC nicht mehr erreichbar ist? PrĂŒf mal bitte, ob der lĂ€uft (sudo service apache2 status). Das klingt mir aus dem Bauch heraus wie ein Problem auf Webserver-Seite.

Der Apache2 scheint zu laufen. Kann ich erst erneut prĂŒfen, wenn die Kiste wieder hĂ€ngt.
Welches Log und nach was genau sollte ich durchsuchen? /var/log/apache2/error.log?
cat /var/log/apache2/error.log |grep error und tail -f /var/log/apache2/error.log
viele "script xy php7:error"vorhanden. Ich kann auch mit SSH auf den Pi zugreifen. Das funktionierte bei einer der vorherigen Installationen nicht.
Das fertige Image habe ich nicht zum Laufen bekommen. Da fehlt mir auch /User und Password, um mit SSH etwas zu tun.

https://docs.nextcloudpi.com/en/how-to-configure-nextcloudpi/

Login with user pi and password raspberry.

Das wird mit deinem Kenntnisstand einfacher sein neu sauber zu Installieren.

Genau da fangen die Probleme, da wird dir niemand so recht helfen können.
Du scheinst selbst nicht genau zu wissen, wie Du installiert hast.

Im Prinzip nach dieser Anleitung:
https://forum-raspberrypi.de/attachment/29543-nextcloud-mit-apache2-mariadb-phpmyadmin-und-letsencrypt-2021-01-11-pdf/

Ich habe noch Hoffnung, dass sich mein Kenntnisstand erweitert. Sonst braucht ja niemand eine Schule besuchen. Mit dem Kenntnisstand


Die von dir angeforderte Seite wurde nicht gefunden. Bitte ĂŒberprĂŒfe die Adresse oder geh zurĂŒck auf die Startseite.

ZurĂŒck zur vorherigen Seite

Und “im Prinzip” sagt gar nichts.
Das kann so oder so sein.

Den Punkt 1.5.0 Letsencrypt installieren habe ich ausgelassen. Soviel zu “im Prinzip”
Nextcloud lÀuft jetzt 18 h ohne AufhÀnger.

Dein Link funktioniert nicht.
Wir wissen nicht was Du getan hast.

Eigenartig. Wenn ich auf den Link klicke (Edge-Browser) öffnet sich ein Dokument mit einer Anleitung!

https://forum-raspberrypi.de/attachment/29543-nextcloud-mit-apache2-mariadb-phpmyadmin-und-letsencrypt-2021-01-11-pdf/

Vermutlich, weil Du einen Account dort hast und eingeloggt bist.
Hier geht nix.

Stimmt. Bin dort angemeldet. Das ist doof. Aber im Prinzip funktioniert ja NC auch seit 24 h. Meine eigentliche Frage war ja, wie suche ich am besten Fehler. ZB. wenn ich nicht mehr den Link auf mein NC öffnen kann. - Seite nicht gefunden. Nach Neustart des Pi geht es aber wieder. Sicher sehr schwer zu beantworten. Gibt es ein Logfile, wo etwas relevantes gespeichert sein könnte?