Nextcloud auf Proxmox als LXC Probleme mit 502

Hallo liebe Community,

Ich habe von wegen ein Textsystem mit Proxmox ausgestattet dort ein Ubuntu LXC mit Ubuntu 20.04 mit Nextcloud 21.0.2.1 und auch eine LXC mit Ubuntu auf dem ein Nginx Proxy Manager (NPM) läuft. meine Internet Adresse ist mit der IP der Nextcloud auch verknüpft und SSL ist auch vorhanden und funktioniert.

Die Netzcloud lies sich nach der Installation auch aufrufen habe dann einige Sachen wieTalk deck contacts usw installiert. nur jetzt bekomme ich immer den Fehler 502 Bed request, NPM weist keine fehler auf und Nextcloud ist über die IP ganz normal zu erreichen ohne Probleme. weiß jemand woran es liegen kann.

LG

Techiesgeek

Ich würde zunächst mal die Logdateien durchforsten

Wo finde ich denn die logdatein?

LG

techiesgeek

So jetzt ein kleines Update:

Die nextcloud ist wieder erreichbar ohne mein Zutun. Jedoch steht unter der anmelde maske das aufgrund von zu vielen anmelde versuchen von dieser ip die Anmeldung um 30 Sekunden verzögert wird.
Die einzige Instanz ist der Chrome Browser mehr auch nicht und der hat keine anmelde versuche mehr probiert da der entsprechende PC aus ist und sich seit Erstellung dieses Posts denn PC nicht wieder genutzt habe.

Echt alles Misteriös.

Hier mal aus dem nginx ordner der error.log

  GNU nano 4.8                                                         error.log                                                                    

2021/05/29 17:31:23 [warn] 10915#10915: “ssl_stapling” ignored, no OCSP responder URL in the certificate “/etc/ssl/certs/ssl-cert-snakeoil.pem”
2021/05/29 17:31:50 [warn] 11339#11339: “ssl_stapling” ignored, no OCSP responder URL in the certificate “/etc/ssl/certs/ssl-cert-snakeoil.pem”
2021/05/29 17:34:02 [warn] 11701#11701: “ssl_stapling” ignored, no OCSP responder URL in the certificate “/etc/ssl/certs/ssl-cert-snakeoil.pem”
2021/05/29 17:34:20 [warn] 13918#13918: “ssl_stapling” ignored, no OCSP responder URL in the certificate “/etc/ssl/certs/ssl-cert-snakeoil.pem”
2021/05/29 17:42:50 [warn] 13921#13921: *556 an upstream response is buffered to a temporary file /var/cache/nginx/fastcgi_temp/1/00/0000000001 whi>
2021/05/29 17:42:50 [warn] 13920#13920: *557 an upstream response is buffered to a temporary file /var/cache/nginx/fastcgi_temp/2/00/0000000002 whi>
2021/05/29 17:42:50 [warn] 13921#13921: *560 an upstream response is buffered to a temporary file /var/cache/nginx/fastcgi_temp/3/00/0000000003 whi>
2021/05/29 17:42:50 [warn] 13921#13921: *562 an upstream response is buffered to a temporary file /var/cache/nginx/fastcgi_temp/4/00/0000000004 whi>
2021/05/29 17:42:50 [warn] 13921#13921: *564 an upstream response is buffered to a temporary file /var/cache/nginx/fastcgi_temp/5/00/0000000005 whi>
2021/05/29 17:42:50 [warn] 13921#13921: *568 an upstream response is buffered to a temporary file /var/cache/nginx/fastcgi_temp/6/00/0000000006 whi>
2021/05/29 17:42:50 [warn] 13921#13921: *572 an upstream response is buffered to a temporary file /var/cache/nginx/fastcgi_temp/7/00/0000000007 whi>
2021/05/29 17:42:51 [warn] 13921#13921: *596 an upstream response is buffered to a temporary file /var/cache/nginx/fastcgi_temp/8/00/0000000008 whi>
2021/05/29 17:42:51 [warn] 13921#13921: *600 an upstream response is buffered to a temporary file /var/cache/nginx/fastcgi_temp/9/00/0000000009 whi>
2021/05/29 17:42:51 [warn] 13921#13921: *598 an upstream response is buffered to a temporary file /var/cache/nginx/fastcgi_temp/0/01/0000000010 whi>
2021/05/29 17:43:34 [warn] 13921#13921: *946 an upstream response is buffered to a temporary file /var/cache/nginx/fastcgi_temp/1/01/0000000011 whi>
2021/05/29 17:44:24 [warn] 13920#13920: *1074 an upstream response is buffered to a temporary file /var/cache/nginx/fastcgi_temp/2/01/0000000012 wh>
2021/05/29 17:45:50 [warn] 13921#13921: *1461 an upstream response is buffered to a temporary file /var/cache/nginx/fastcgi_temp/3/01/0000000013 wh>
2021/05/29 21:13:06 [warn] 13920#13920: *11251 an upstream response is buffered to a temporary file /var/cache/nginx/fastcgi_temp/4/01/0000000014 w>
2021/05/29 21:23:47 [warn] 13920#13920: *16819 an upstream response is buffered to a temporary file /var/cache/nginx/fastcgi_temp/5/01/0000000015 w>
2021/05/30 09:42:03 [warn] 174#174: “ssl_stapling” ignored, no OCSP responder URL in the certificate “/etc/ssl/certs/ssl-cert-snakeoil.pem”

hier einmal aus dem selben Ordner die access.log

192.168.178.135 - - [29/May/2021:17:37:29 +0000] "GET / HTTP/1.1" 301 162 "-" "Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML,>

192.168.178.135 - - [29/May/2021:17:37:30 +0000] “GET / HTTP/1.1” 301 162 “-” "Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML,>
192.168.178.135 - - [29/May/2021:17:37:30 +0000] “GET / HTTP/1.1” 301 162 “-” "Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML,>
192.168.178.135 - - [29/May/2021:17:37:30 +0000] “GET / HTTP/1.1” 301 162 “-” "Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML,>
192.168.178.135 - - [29/May/2021:17:37:30 +0000] “GET / HTTP/1.1” 301 162 “-” "Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML,>
192.168.178.135 - - [29/May/2021:17:37:30 +0000] “GET / HTTP/1.1” 301 162 “-” "Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML,>
192.168.178.135 - - [29/May/2021:17:37:30 +0000] “GET / HTTP/1.1” 301 162 “-” "Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML,>
192.168.178.135 - - [29/May/2021:17:37:30 +0000] “GET / HTTP/1.1” 301 162 “-” "Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML,>
192.168.178.135 - - [29/May/2021:17:37:30 +0000] “GET / HTTP/1.1” 301 162 “-” "Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML,>
192.168.178.135 - - [29/May/2021:17:37:30 +0000] “GET / HTTP/1.1” 301 162 “-” "Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML,>
192.168.178.135 - - [29/May/2021:17:37:30 +0000] “GET / HTTP/1.1” 301 162 “-” "Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML,>
192.168.178.135 - - [29/May/2021:17:37:30 +0000] “GET / HTTP/1.1” 301 162 “-” "Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML,>
192.168.178.135 - - [29/May/2021:17:37:30 +0000] “GET / HTTP/1.1” 301 162 “-” "Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML,>
192.168.178.135 - - [29/May/2021:17:37:30 +0000] “GET / HTTP/1.1” 301 162 “-” "Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML,>
192.168.178.135 - - [29/May/2021:17:37:30 +0000] “GET / HTTP/1.1” 301 162 “-” "Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML,>
192.168.178.135 - - [29/May/2021:17:37:30 +0000] “GET / HTTP/1.1” 301 162 “-” "Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML,>
192.168.178.135 - - [29/May/2021:17:37:30 +0000] “GET / HTTP/1.1” 301 162 “-” "Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML,>
192.168.178.135 - - [29/May/2021:17:37:30 +0000] “GET / HTTP/1.1” 301 162 “-” "Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML,>
192.168.178.135 - - [29/May/2021:17:37:30 +0000] “GET / HTTP/1.1” 301 162 “-” "Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML,>
192.168.178.135 - - [29/May/2021:17:37:30 +0000] “GET / HTTP/1.1” 301 162 “-” "Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML,>
192.168.178.135 - - [29/May/2021:17:37:30 +0000] “GET / HTTP/1.1” 301 162 “-” "Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML,>
192.168.178.135 - - [29/May/2021:17:37:32 +0000] “GET / HTTP/1.1” 301 162 “-” "Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML,>
192.168.178.135 - - [29/May/2021:17:37:32 +0000] “GET / HTTP/1.1” 301 162 “-” "Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML,>
192.168.178.135 - - [29/May/2021:17:37:32 +0000] “GET / HTTP/1.1” 301 162 “-” "Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML,>
192.168.178.135 - - [29/May/2021:17:37:32 +0000] “GET / HTTP/1.1” 301 162 “-” "Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML,>
192.168.178.135 - - [29/May/2021:17:37:32 +0000] “GET / HTTP/1.1” 301 162 “-” "Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML,>
192.168.178.135 - - [29/May/2021:17:37:32 +0000] “GET / HTTP/1.1” 301 162 “-” "Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML,>
192.168.178.135 - - [29/May/2021:17:37:32 +0000] “GET / HTTP/1.1” 301 162 “-” "Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML,>
192.168.178.135 - - [29/May/2021:17:37:32 +0000] “GET / HTTP/1.1” 301 162 “-” "Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML,>
192.168.178.135 - - [29/May/2021:17:37:32 +0000] “GET / HTTP/1.1” 301 162 “-” "Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML,>
192.168.178.135 - - [29/May/2021:17:37:32 +0000] “GET / HTTP/1.1” 301 162 “-” "Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML,>
192.168.178.135 - - [29/May/2021:17:37:32 +0000] “GET / HTTP/1.1” 301 162 “-” "Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML,>
192.168.178.135 - - [29/May/2021:17:37:32 +0000] “GET / HTTP/1.1” 301 162 “-” "Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML,>
192.168.178.135 - - [29/May/2021:17:37:32 +0000] “GET / HTTP/1.1” 301 162 “-” "Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML,>
192.168.178.135 - - [29/May/2021:17:37:32 +0000] “GET / HTTP/1.1” 301 162 “-” "Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML,>

kann damit jemand was anfangen?

Nachtrag die IP mit der 135 am ende ist der Proxy manager

Ich würde mal nachschauen was die Fehlermeldungen zu bedeuten haben und die dann ausmerzen.

Den würde ich zunächst mal weglassen und zuerst die Nextcloud-Instanz zum Laufen bringen.

Die nextcloud funktioniert tip top, sofern mann nur über die intern IP aufrufen tit soweit ich versuche mit meiner Internet adresse versuche drauf zuzugreifen bekomme ich immer den fehler 502 fehler und auch das mit dem 30 sekunden warten das verschwindet auch nicht.

@techiesgeek Dann liegt der Fehler irgendwo in der Reverse Proxy Konfiguartion oder in den relavanten Parametern der config.php. Ich bin leider kein Experte was nginx betrifft und nutze auch keinen Reverse Proxy für meine Nextcloud. Aber vielleicht hilft dir ja die Doku weiter. Stichworte: Trusted Proxies und Overwrite Parameter.

https://docs.nextcloud.com/server/latest/admin_manual/configuration_server/reverse_proxy_configuration.html

@bb77 da muss ich mich erstmal durch fuchsen!

Ich benutze wie oben ja steht proxmox und habe damit auch ein Cluster aufgebaut besteht aus Server 1-8, wenn ich jetzt denn Server 1 mit dem NPM 192.168.178.135 abstelle und stattdessen den Proxy auf Server 2 frisch installiere bestehen die Probleme weiterhin. Fahre ich den Server 1 komplett runter und lasse diesen aus funktioniert auch die nextcloud und Proxy sowie die Webadresse ohne Fehler.

Jetzt steh ich komplett ratlos da.

LG Techiesgeek.

Ich ehrlich gesagt auch. :wink: Was hat den der Proxmox Cluster mit den Applikationen in deinen LXC Containern zu tun? Normalerweise sollten Container und VMs eine Fixe IP haben, die sich nie ändert.

Für mich sieht das nach einem grundlegenderen Netzwerkproblem aus. Entweder ein Problem mit der Netzwerk-/Firewallkonfiguration auf den Proxmox Servern, oder irgendwo etwas falsch konfiguriert in einem vorgeschaltetetn Switch oder Firewall. An der Konfiguration des NPM oder der Nextcloud kann es ja eher nicht liegen, wenn es in gewissen Konstelationen funktioniert. Ich denke mal dein Problem ist eher ein Fall für das Proxmox Forum…

@bb77 Ja darüber habe ich auch schon nachgedacht nur es ist wirklich schleicherhaft wieso jetzt wieder alles geht im Prinzip sollte das ja alles egal sein wo der proxy im cluster sich befindet sofern der Proxy auf die richtige Ip zeigt. werde mir gleich mal ein acc im Proxmox forum erstellen und da mal schauen ob es dort schon solche fälle gab. danke dir @bb77 und @Sanook trotzdem für eure mühe.

LG

Techiesgeek

PS. Sollte ich das Problem beheben könne und weis woran es lag werde ich den Lösungsweg hier nochmal posten.

1 Like

Guten Abend alle zusammen.

So hab heute mal ins Proxmox geschrieben und prompt eine Antwort bekommen, Jedoch konnten auch die mir nicht helfen, da selbst die logs in Proxmox nicht eindeutig waren.

Bis ich auf eine IP Gestoßen bin mit der ich überhaupt nicht anfangen konnte, und da stellte sich raus das ein altes iPhone meiner Frau noch eine Talk und Nextcloud Zugang auf die Internet Adresse hatte und sich natürlich versucht hat anzumelden, aber wieso auch immer dachte dann die Nextcloud es wäre ein Hackerangriff und hat 502 ausgespuckt und dauerhaft die 30 Sekunden Anmeldeverzögerung, nachdem ich die Apps vom iPhone gelöscht habe hat sich nach einen Neustart der Server alles wieder eingependelt und seit 12 stunden läuft hier alles Ohne Probleme.

1 Like