Nextcloud Assistant - testing not working

Nextcloud version (eg, 20.0.5): 27.1.2
Operating system and version (eg, Ubuntu 20.04): 22.04
Apache or nginx version (eg, Apache 2.4.25): Apache 2.4.52
PHP version (eg, 7.4): 8.1.2

The issue you are facing trying to test the Nextcloud assistant, have installed LLM and Assistant apps. I cannot see any error message except that it has failed. The notification comes through that is has not worked but I have no idea why. What could I be missing

Assistant app is installed
LLM is installed and models

what is the obvious thing I am missing, thank you

The LLM page indicates that all installed correctly and working


Machine learning model has been downloaded successfully.
The app was installed successfully and will run prompts in background processes on request.

Model settings

Machine learning model has been downloaded successfully.
Choose the machine learning model to be used.

Inference settings

The number of threads to use for inference (more is faster)


Python executable executed successfully and setup works.

Same here. Same config.

Some problem here. Same config, same symptoms.

Problem remains in Nextcloud release 27.1.3

Are there instructions somewhere to get assistant and LLM installed?

Same issue, same configuration, same story.

I’m not a professional but a beginner. Anyway, I was intrigued by this local llm thing since the announcement, so, after a bit of research, I have downloaded and installed the assistant and the local large language model apps (@ninjajellybean I have it installed downloading it from github GitHub - nextcloud/llm: A Nextcloud app that packages a large language model (Llama2 / GPT4All Falcon), place it in the apps folder of my NC server, and then installed it simply through the NC web interface.

Since then I have tried several times to make it work, both with the Llama and with the Falcon model, but I always get the same error/notification: “task for Nextcloud Assistant has failed”.