Nextcloud Assistance with RP change

Backstory: Recently I took my apache2 reverse proxy off the same machine that is running NextCloud/everything else. This way I would not any ports open to main VLAN of my network from the internet. My new RP is a Pi4 and is using the same config files that were working fine until the switch. All my config files except for NextCloud are up and running with no issues. I have redone the LetsEncrypt cert a few times for my FQDN since migrating the to the Pi4 since some of my early research indicated this might have been the cause.

Issues: going to the correct domain ( on my laptop’s Chrome browser redirects to Bing (I have a catchall setup to do this). If I do it in Incognito mode I get to the NextCloud login, where it says "The server was unable to complete your request. If this happens again, please send the technical details below to the server administrator. More details can be found in the server log. ".

If I try it from my phone’s browser I get the same result as Incognito mode. If I try it with the android NextCloud app it says the server is in maintenance mode. I get the same result on the same network or a different network as the RP and server (I have not moved RP to a new VLAN until I fix this).

Any advice would be appreciated on solving this. I have beat my head against the wall for to long on this. If you need more information please do not hesitate to ask. All my other reverse proxies work just fine, it is something to do with NextCloud, my config, and the new RP’s ip address I bet.


Loaded/restarted apache2 file.

NextCloud docker

NextCloud logs from portainer