Nextcloud: App page is not loading

I installed Nextcloud on our server and everything works fine - except the apps page. It is not loading - only the circles are spinning.

I already ran this script, but it didn’t help me (https://docs.nextcloud.com/server/11/admin_manual/installation/installation_wizard.html#strong-perms-label)

Any ideas how to fix this?

Did you check your logfiles?

Hi all,
I do have the same issue here. Everything worked fine for me on Nextcloud 9.
Today, I upgraded to 10, and my apps were gone. The app page was no longer loading. I fiddled around a bit, but could not find any error. I therefore upgraded to 11 straight away. Upgrade went fine, just as upgrade to 10.

However, the apps page only shows the spinning circle forever. I took a look at the logs, which do not seem to help a lot:

root@pid:/var/opt/nextcloud/data# tail nextcloud.log
{“reqId”:“Plagzkh4hd6Y4QvweeB0”,“remoteAddr”:“85.197.30.92”,“app”:“admin_audit”,“message”:“Login successful: “kumzugloom””,“level”:1,“time”:“2017-03-19T10:56:48+00:00”,“method”:“POST”,“url”:"/nextcloud/index.php/login",“user”:“kumzugloom”,“version”:“11.0.2.7”}
{“reqId”:“toqphZvG+UvfJU5y6bLn”,“remoteAddr”:“85.197.30.92”,“app”:“no app in context”,“message”:“Current user is not logged in”,“level”:0,“time”:“2017-03-19T10:58:12+00:00”,“method”:“GET”,“url”:"/nextcloud/index.php/settings/apps",“user”:"–",“version”:“11.0.2.7”}
{“reqId”:“C4/vQRs4SJs7EQ8hXaik”,“remoteAddr”:“85.197.30.92”,“app”:“admin_audit”,“message”:“Login attempt: “kumzugloom””,“level”:1,“time”:“2017-03-19T10:58:20+00:00”,“method”:“POST”,“url”:"/nextcloud/index.php/login?redirect_url=/nextcloud/index.php/settings/apps",“user”:"–",“version”:“11.0.2.7”}
{“reqId”:“C4/vQRs4SJs7EQ8hXaik”,“remoteAddr”:“85.197.30.92”,“app”:“admin_audit”,“message”:“Login successful: “kumzugloom””,“level”:1,“time”:“2017-03-19T10:58:20+00:00”,“method”:“POST”,“url”:"/nextcloud/index.php/login?redirect_url=/nextcloud/index.php/settings/apps",“user”:“kumzugloom”,“version”:“11.0.2.7”}
{“reqId”:“Ox31S44Qt0fEpLKEM5bv”,“remoteAddr”:“85.197.30.92”,“app”:“DeleteOrphanedItems”,“message”:“0 orphaned system tag relations deleted”,“level”:0,“time”:“2017-03-19T10:58:32+00:00”,“method”:“GET”,“url”:"/nextcloud/cron.php",“user”:"–",“version”:“11.0.2.7”}
{“reqId”:“Ox31S44Qt0fEpLKEM5bv”,“remoteAddr”:“85.197.30.92”,“app”:“DeleteOrphanedItems”,“message”:“0 orphaned user tag relations deleted”,“level”:0,“time”:“2017-03-19T10:58:32+00:00”,“method”:“GET”,“url”:"/nextcloud/cron.php",“user”:"–",“version”:“11.0.2.7”}
{“reqId”:“Ox31S44Qt0fEpLKEM5bv”,“remoteAddr”:“85.197.30.92”,“app”:“DeleteOrphanedItems”,“message”:“0 orphaned comments deleted”,“level”:0,“time”:“2017-03-19T10:58:32+00:00”,“method”:“GET”,“url”:"/nextcloud/cron.php",“user”:"–",“version”:“11.0.2.7”}
{“reqId”:“Ox31S44Qt0fEpLKEM5bv”,“remoteAddr”:“85.197.30.92”,“app”:“DeleteOrphanedItems”,“message”:“0 orphaned comment read marks deleted”,“level”:0,“time”:“2017-03-19T10:58:32+00:00”,“method”:“GET”,“url”:"/nextcloud/cron.php",“user”:"–",“version”:“11.0.2.7”}
{“reqId”:“vHc3LO2THfK8u7MQI9pz”,“remoteAddr”:“85.197.30.92”,“app”:“no app in context”,“message”:“Invalidating session tokens older than 2017-03-18T11:05:42+00:00”,“level”:0,“time”:“2017-03-19T11:05:42+00:00”,“method”:“GET”,“url”:"/nextcloud/cron.php",“user”:"–",“version”:“11.0.2.7”}
{“reqId”:“vHc3LO2THfK8u7MQI9pz”,“remoteAddr”:“85.197.30.92”,“app”:“no app in context”,“message”:“Invalidating remembered session tokens older than 2017-03-04T11:05:42+00:00”,“level”:0,“time”:“2017-03-19T11:05:42+00:00”,“method”:“GET”,“url”:"/nextcloud/cron.php",“user”:"–",“version”:“11.0.2.7”}

I also checked /var/log/syslog, but there was no error in there as well.
As I was continuously upgrading from some old owncloud version, I was wondering, whether my config file might be too old? It looks very different from the sample file:

<?php $CONFIG = array ( 'instanceid' => 'ocbwcpt85gvm', 'passwordsalt' => '<>>', 'secret' => '<>>', 'trusted_domains' => array ( 0 => '<>>', 1 => '<>>', ), 'datadirectory' => '/var/opt/nextcloud/data/', 'overwrite.cli.url' => '<>>/nextcloud', 'dbtype' => 'sqlite3', 'version' => '11.0.2.7', 'logtimezone' => 'UTC', 'installed' => true, 'maintenance' => false, 'loglevel' => 0, 'updater.secret' => '<>>',

);

Can someone help me? I use NC to sync my calendar & contact entries with my girlfriend and don’t want to risk a discussion, on why I have to host this on a private Raspberry instead of using google calendar or some other data squid… :wink:

Thanks a lot!

Update:
I also did run the permission script.
In this Thread, it says:

Is “appstoreurl” defined in your config.php? If so remove the line or set it to “https://api.nextcloud.com/v1” as this is the new standard app store and therefore also standard value.

Also “appstoreenabled” should be set to “true” but I guess this is already the case.

However, the mentioned URL seems to be invalid?

Also here are some additional system infos:
Up-to-date Rasbian, nginx/1.6.2, PHP 5.6.29-0+deb8u1 (cli)

The updater secret should not be necessary after successful nextcloud upgrade.

The appstoreurl was only necessary a short time after nc 11 release and new app store introduction, but now as far as I know the entry will be just ignored (same as appstoreenabled) and new standard app store used in any case.

Try to remove the three entries, otherwise your config.php looks fine.

Hey, yes I checked the logfile in /var/www/nextcloud/data/nextcloud.log. I didn’t find there anything about the appspage.

Today it loaded once, but it took about 15-20 minutes to load…

A small update.

The page is loading, but very very (very very) slowly… Is it possible to load it faster?

Hmm, for me it is loading quite instantly, so it’s not the app store servers fault.

Which browser are you using? Did you check the browser console for possible errors and tried another one?

Some additional system infos (webserver, database, php version etc.) could be possibly helpful and also check your webserver log files for entries during app page loading attempt.

You installed nextcloud new? So I guess there are not app store related entries in your config.php, as @kumzugloom tried in between, right? Have to be careful to not mix you guys up ;).

Currently google chrome is my standard browser - I didn’t see there any errors. I’ve also tried firefox but I got the same loading time problem.

OS = Ubuntu 16.04.1 LTS
Webserver = apache2
PHP = 7.0.15
database = mariadb

Here is also my config.php

<?php $CONFIG = array ( 'instanceid' => '###', 'passwordsalt' => '###', 'secret' => '###', 'trusted_domains' => array ( 0 => '192.168.xxx.xxx', ), 'datadirectory' => '/var/www/nextcloud/data', 'overwrite.cli.url' => 'http://192.168.xxx.xxx/nextcloud', 'dbtype' => 'mysql', 'version' => '11.0.2.7', 'dbname' => 'nextclouddb', 'dbhost' => 'localhost', 'dbport' => '', 'dbtableprefix' => 'oc_', 'dbuser' => 'nextclouduser', 'dbpassword' => 'nextcloudpassword', 'logtimezone' => 'UTC', 'installed' => true, 'loglevel' => 0, 'apps_paths' => array( array( 'path'=> '/var/www/nextcloud/apps', 'url' => '/apps', 'writable' => true, ), ), ); I see that the "dbtype" in the config.php is mysql instead of mariadb. If I type mysql into the console then mariadb will start... Is this normal? (It is the first time I use mariadb)

Was “app_paths” a try to fix the problem? As you use standard paths, this entry should not be necessary, but should indeed also not lead to problems.

As MariaDB is a fork of MySQL, most commands and syntax are still the same. So it is normal that you use the mysql commands in terminal and "mysql’ is still database type in config.php.

Hmm so far I have no idea, what could cause your issue. But there are some general performance tweaks you could try, e.g. memory caching: https://docs.nextcloud.com/server/11/admin_manual/configuration_server/server_tuning.html

Other pages of nextcloud web ui load fast, e.g. browsing large file lists or contacts/calendar?

Hey, sorry for the late response…

Yes - “app_paths” was a try to fix my problem :slight_smile:

I tried to install APCu (memory caching) - since I have ubuntu 16.04, I couldn’t use the instructions here 1:1 https://docs.nextcloud.com/server/11/admin_manual/configuration_server/caching_configuration.html

So I installed apcu with this command: apt-get install php-apcu
After that I added this line to my config.php: ‘memcache.local’ => ‘\OC\Memcache\APCu’,
Then I restarted the web server (apache2) and tried to load the apps page again - still the same problem.

– I got no SSL encryption yet –

Once the apps page loaded, I can enable and disable the apps within seconds.

Today I had once again time, to take a look at that issue. I thought it might be worth to proceed as slow as possible in order to narrow down, where the issue happens.
My currently installed version was (9.1.1.2) which in fact does not exist. but based on the last modified date of many files, it was easy to see, that I have probably Nextcloud 9.0.54 installed.
Even here, my App page does not load. However it must have loaded at some point, as I have calendar and contacts activated?!
I therefore tried to upgrade to 9.0.55. Upgrade went fine, in fact I created a script to stick exactly to what the guide says (https://docs.nextcloud.com/server/10/admin_manual/maintenance/manual_upgrade.html):

#!/bin/bash -x

wwwfol='/var/www/html'
datfol='/var/opt/nextcloud/data/'

service nginx stop
cd $wwwfol

prefol=$(date +%Y-%m-%d_%H-%M-%S)

mv nextcloud $prefol 
tar xjf nextcloud-9.0.57.tar.bz2
cp $prefol/config/config.php ./nextcloud/config/config.php
# cp -rn $prefol/apps/* ./nextcloud/apps/
cp -rn $prefol/apps/contacts ./nextcloud/apps/
cp -rn $prefol/apps/calendar ./nextcloud/apps/
/root/nextcloud_folder_settings.sh

service nginx start
cd ./nextcloud

sudo -u www-data php occ upgrade

sudo -u www-data php occ maintenance:mode --off

echo 'Completed.'

I’m again totally confused. What is my nextcloud version really? And did it change, since installation, as I was obviously able to activate calendar & contacts?