Nextcloud API URL (behind reverse proxy)

Hi everyone, I’ve got a Nextcloud instance running in a VPS using the docker-compose file found here: It works, but it looks like Nextcloud doesn’t recognize that it’s behind a reverse proxy for ssl, so it reports all of its API URLs as http://. I need them to be https:// in order for managed XMPP hosting to work with jsxc, but the UI doesn’t let me edit the fields. Is there a config change I need to make? I am still learning to use Docker, but I have run my own Nextcloud instance for over a year.

Hi, and welcome - you can try one of the overwrite options, they are useful for those proxy problems. Try this one first:

‘overwriteprotocol’ => ‘https’

There are some others you may try if you still get problems, check here for more info:

Running nextcloud in a docker myself, works great :slight_smile: