Nextcloud and php 8.x

Hello,
which Version of NC will be compatible with PHP8?

Not a current stable one. It must be one of the next major releases, @kesselb do you know if NC 21 will be compatible? NC 21 is scheduled for February 2021.

1 Like

I suppose so: https://github.com/nextcloud/server/pull/22767

Some CI jobs are already running PHP 8. Documentation still recommends 7.3 and 7.4.

4 Likes

OK, thanks for this Info :grinning:

It is mentioned on issues related to the pull that development plans for a version 21 release eta of PHP 8.x.