Nextcloud AIO will not install correctly

Hey everybody6, first of all I would like to thank the Nextcloud team for the wonderful and spectacular work of the Nextcloud project, I truly appreciate it and love using it. I did run into some issues that I just cannot get to fix. I have tried for months to figure out and find a solution via all available resources, Github, Google, and this Forum as well.
The issue: I recently tried to spin up a Nextcloud AIO instance as my previous Nextcloud instance completely crashed and I was unable to recover anything what so ever (long story). For the last two months, it has been an ongoing battle to get it figured out.
The problem: I was able to deploy Nextcloud AIO instance, however upon startup it has the “page loading, will reconnect in 5 seconds” “not logged in” and after some time (after I create some users) I cannot log in with them at all and it says wrong username and password. I have tried all the possible topics but maybe I’m just not seeing or reading the solution in front me. Please help.
Current setup:
Alma Linux 9.1 virtual machine on a TrueNAS Scale 22.12.0 Hypervisor. The Nextcloud instance would be deployed on the VM via docker compose on Portainer but the data would be stored on a mounted folder on a dataset on TrueNAS. Latest everything.
Tried: Deploying on two different hypervisors, 3 different types of lInux distros (including Debian, Ubuntu, and Alma Linux), and have tried only deploying without any mounted storage. Am I missing something? Did I misunderstand other posts? Am willing to be replied to posts that are identical to mine and try again. Would like to thank in advance for all the support!

Just to clarify, is this on the Nextcloud login page or the AIO admin page?

Yes that is correct, this mainly happens on the Nextcloud login in page. I do not have any issues with the AIO admin page.