Nextcloud AIO Ios apps not working

Nextcloud version (eg, 20.0.5): Latest AIO, 29
Operating system and version (eg, Ubuntu 20.04): Raspberry Pi Os Lite 64 bit
Apache or nginx version (eg, Apache 2.4.25): AIO
PHP version (eg, 7.4): AIO

The issue you are facing:
Hello, I got a raspberry pi and thought it would be nice as a Nextcloudserver, looked installationmethodes up from the Internet, found the All in one docker image and got ahead. Everything worked fine until I saw a error in the Nextcloud admin settings:
Your web server is not properly set up to resolve .well-known URLs, failed on: /.well-known/caldav I then installed news feed, notes and deck they worked fine, until I tried to log in on the iOS apps for deck notes and news feed. On News feed the synchronisation takes forever, on notes the error 401 appears and on deck it’s the same. I even installed nextcloud AIO 28, same problam without the error in the admin settings.I’m a total newbie and any help is appreciated.

Is this the first time you’ve seen this error? (Y/N):N

Steps to replicate it:

  1. Install Nextcloud over AIO
  2. Install Notes, deck and news feed
  3. try to log in in iOS apps

The output of your Nextcloud log in Admin > Logging:

/ None

The output of your config.php file in /path/to/nextcloud (make sure you remove any identifiable information!):

None

The output of your Apache/nginx/system log in /var/log/____:

None
``
NONE

Output errors in nextcloud.log in /var/www/ or as admin user in top right menu, filtering for errors. Use a pastebin service if necessary.
None

Update:
I have used an domain, wicch i used in prevouse nextcloud installs. With a new domain i get an time out error.

A login via browser (also test outside your home network) works?

Yes, I can access those from the Web, but not from the iOS apps as described above

Do you only use Nextcloud AOI or do you have a reverse proxy in front of it?

Only Nextcloud AIO, I haven’t setup a reverse proxy.

What do you see if you open /.well-known/caldav directly in the browser? If everything works, a Basic Auth login screen should be visible.

The I get this line showed:
This is the WebDAV interface. It can only be accessed by WebDAV clients such as the Nextcloud desktop sync client. When I acces it in a browser where I never logged on n, I get the basic login.I can log in though in the official Nextcloud iOS app and the password app, just notes, deck and news apps aren’t working as described above.

Update
When I try in to log in the notes app, this is the error in my adminlogs:
App token login name does not match

Okay, that’s good.

There are 2 issues on GitHub that sound somewhat similar to the problem you described. In both cases, reinstalling the Android app (or deleting the app data, which has the same effect) helped.

I don’t know if that will help you. But it’s worth a try.

Thanks, that worked!

This topic was automatically closed 8 days after the last reply. New replies are no longer allowed.