Nextcloud AIO install - Fails to find OPEN port 443 open

Here is an image side by side.
i am running the AIO installation on an ubuntu 20.04 server in plain vanilla/updated state, no firewall / router forwading ports 80/443 to the server ( (i did a test installing apache and i am able to access it from a remote location via the domain name).
I am using a subdomain which has been pointed to the IP more than 48 hours ago and is resolving perfectly fine to the IP of this installation.
I am able to flick the switch on the firewall router, on and off for ports 443/80 and they take immediate effect. And finally, the test suggested by the nextcloud installer on CONFIRMS, port 443 is open.
I am typing the domain perfectly fine in the input box of the AIO setup page in the screenshot attached.
The ubuntu server is a VM under TrueNAS.

Any ideas where else i could check?
I run the installation TWICE, restoring the server to the initial fresh ubuntu setup.
/etc/hostname and /etc/hosts already setup with the complete subdomain i am using for this server.
Finally, as the last obvious test confirmation, if i shut down the ubuntu server VM where i am running the AIO setup, shows me port 443 is CLOSED. Confirming there was no issue whatsoever to reach the AIO install.

Any ideas where else i can look?
Thank you

I may have seen this issue in the past. Did you enable ipv6 for docker correctly?

Also is the port really open for that domain? Seems like you’ve entered your ip-address and not your domain in

Additonally, can you send the docker run command or the docker-compose file that you’ve used?

here is another screenshot.
Thank you for the ideas.
I have tried now re-checking that there was not an IP change, and tested using the domain instead of the IP on
My terminal resolves the subdomain to the right IP, i am copying and pasting, there are no mistakes.

About the other settings.
I am following the installation instrucctions in the nextcloud github page here: GitHub - nextcloud/all-in-one: Nextcloud AIO stands for Nextcloud All In One and provides easy deployment and maintenance with most features included in this one Nextcloud instance.

I have installed another server using the same procedure at another location and the whole thing is just running one single command on a fresh installed server, there is no need to configure ip6, individual docker containers or anything, it is all automatic. That other installation went perfectly fine, so i am puzzled here why is till not finding the port, but everything else does,


At this point i am convinced there is a problem with the docker install on github. PERIOD.

I setup a different ubuntu server on a different Virtual enviroment server in the same network, and i had the same issue with port 443 running the AIO docker install.

Then, I cloned the ubuntu VM where i run the docker command for the AIO installation, i booted it, and manually installed apache and the snap certbot application.
I was able to certbot and get the SSL certificate with letsencrypt on the first try, meaning PORT 443 is working fine letting traffic in on the network.
I can access the plain apache server welcome page, with the encrypted padlock using the subdomain that the Nextcloud AIO fails to use on port 443.
I will have to setup nextcloud manually then or deal with the undocumented nextcloud one click install in TrueNAS here…

Hm… Then not sure what is wrong on your truenas instance… In any case you can skip the domain validation with -e SKIP_DOMAIN_VALIDATION=true if you are completely sure that everything is configured correctly.

Thank you szaimen.
I have a TrueNAS server as the host running this VM.
And also, another Proxmox server on a different physical computer on the same network.
The issue is happening on both of them, i do not think is an issue with the VE. And as i mentioned, if i was able to get a cert and open a padlocked apache page on the same VM i am using for AIO, then there should not be issues with AIO.
I will test the extra switch you suggested, and report back
Thank you

The problem is that I cannot reproduce this. So this issue happens either due to
a configuration issue or due to an issue specific to your infrastructure.

Anyways, the flag will let you pass the validation so that should make it work.

excuse my ignorance here, still learning all this stuff.

I executed the command like this:

sudo docker run -it \
--name nextcloud-aio-mastercontainer \
--restart always \
-p 80:80 \
-p 8080:8080 \
-p 8443:8443 \
--volume nextcloud_aio_mastercontainer:/mnt/docker-aio-config \
--volume /var/run/docker.sock:/var/run/docker.sock:ro \
nextcloud/all-in-one:latest -e SKIP_DOMAIN_VALIDATION=true

And once the containers got pulled and setup, i got this error message (-e invalid option):

If your server has port 80 and 8443 open and you point a domain to your server, you can get a valid certificate automatially by opening the Nextcloud AIO Interface via:
/usr/bin/ line 213: exec: -e: invalid option
exec: usage: exec [-cl] [-a name] [command [argument ...]] [redirection ...]

am i supposed to use the switch somewhere else?

Now when i try to access it does not connect.

This should work:

sudo docker run -it \
--name nextcloud-aio-mastercontainer \
--restart always \
-p 80:80 \
-p 8080:8080 \
-p 8443:8443 \
--volume nextcloud_aio_mastercontainer:/mnt/docker-aio-config \
--volume /var/run/docker.sock:/var/run/docker.sock:ro \

Thank you!!! :sweat_smile:
It worked perfect now!!

I am having performance and collabora issues right off the bat, but ill try to troubleshot and open another thread if needed.

Thank you so much, i spent the whole day yesterday pulling my hairs troubleshoting the network everywhere. The skip domain validation was the solution.

A post was split to a new topic: Skip validation domain in AIO on Virtualbox