NextCloud AIO - Cannot download Big files

Hi , I am facing some problems when downloading files from Nextcloud.


There is no problem when downloading some small files (~ a few MB) from Nextcloud.
However when i try to download a zip file (>5GB) through Chrome, it shows “Network Error”.

When using wget to download the files , it shows followings:

2023-02-23 11:32:10 (107 MB/s) - Read error at byte 63832032/6228407627 (error:0A000119:SSL routines::decryption failed or bad record mac). 

My setup

  • Nextcloud AIO v4.4.1

  • Caddy (as a reverse proxy in front of Nextcloud. Using the config in the reverse-proxy document)

What I’m doing wrong? Thanks!

Sorry i do not use Caddy. But i found this configuration for nginx here.

proxy_buffering off;
client_max_body_size 0;

Maybe you can use it also in Caddy see this documentation

Maybe you can change to nginx to include/exclude Caddy for your error.

Thank you for your reply . I switched to nginx with your suggested configuration. However , same errors occur . Anyway ,thanks for your help

I’ve just tried to download a 3.6 GB iso file of my test-instance and it worked without any problem. The error message that you have been reporting points towards a faulty network infrastructure. Can you check that your network interface and router and related stuff is not mis-behaving?

Also have you tested with different files? Maybe you can copy a new correct file (use checksums) to the linux filesystem and use files:scan --all to integrate the file to your Nextcloud. Then check the download again.

I agree.

Does your Server and Client have good and reliable, strong DNS services for repeated DNS lookups?

Can you open more than 1 terminal session if possible?

Try a normal ping to a well known host and leave it running for 24 hours.
When you stop it.
You should have the stats over the period of time it was running.

Hope that helps. I will need to actually try Nextcloud AIO soon.

After doing some investigation , I found out that I can download big files from the external network but not local network .

After turning off the Fast Forwarding in my Linksys router and setup a seperate DNS for the local network , I am able to download the big files in my local network.

I am not a expert about network infrastructure , but I suspect there are something wrong NAT forwarding in my router. Maybe Linksys routers are very strange…

Thank you for pointing out the faulty network infrastructure.