Nextcloud AIO 9.1.0: LDAP/AD connection errors

Hi,

I’m trying to setup the AIO 9.1.0 instance on my VM.
All containers are up and running (healthy, green).

I installed the “LDAP/AD integration” app for being able to connect to a user storage.

When I enter the server address (either IP, hostname or FQDN) and hit the “Detect port” button it fetches the correct port (at least 389).
Afterward I input my user DN and password, save it and try to detect base DN I always the the following error message:
image

I am 100% sure that the port, DN and pw are correct (as I’ve tested it again).

Inputting the base DN manually won’t work either. The test fails.
The logs only state:

I haven’t set anything else yet (not possible as it’s greyed out).

So what is the issue here?

Thanks for your help in advance.

/nightmare1942

Can you give us an idea of what you’re entering for the User DN and Base DN fields?

Docs: User authentication with LDAP — Nextcloud latest Administration Manual latest documentation

I am 100% sure that the port, DN and pw are correct (as I’ve tested it again).

You can set your Nextcloud loglevel to 0 (debug) and get more information from the LDAP integration app about what is going on.

Hi,
sorry about the log level. I thought I’ve already set it to debug.

Here you can see the DN I use (second log entry).
For the Base DN I just tried to use dc=domain,dc=tld which reflects my domain for testing purposes. I will later narrow and filter it if it works.

For now I’m using the IP for connection to LDAP.

DOes this help more?

Edit:
In one of the OUs there is an underscore. But this worked before with Nextcloud.

Noone has an idea what it might be?