Nextcloud 9.0.51 issue: no “instance id” created at install

Hello, all. I just installed Nextcloud (my first attempt) on CentOS 6.8. Since I am on CentOS 6.8, I used a slightly older set of instructions (linked) that lead to an older verion of PHP getting installed (5.3), which led to me having to overwrite it with the newer PHP version (5.5). I thought this may have caused issues, but after checking I only have the later version of PHP 5.5 installed. However, I got an error when I tried to load :

Internal Server Error

The server encountered an internal error and was unable to complete your request.
Please contact the server administrator if this error reappears multiple times, please include the technical details >below in your report. More details can be found in the server log.

After checking the config.php file (at \var\www\html\nextcloud\config ) I found that it contained NO “instance id.” I did some googling and found a forum that said the instance id can be just randomly created, so I tried. However, this just broke the Nextcloud index.php site and nothing would load. As such, I removed the randomly created (as in I literally just made up a 12 character string) and the original “Internal Server Error” now shows again. Help greatly appreciated. Thank you!

Did you check your server error logs for more details? Could be a missing php module…

Thanks, I abandoned this and installed NC v11 now. Much better!